summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-11-10 11:32:06 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-11-16 14:17:55 +0100
commit4b16683eff6d9f190e38df1e3d85b9e113687623 (patch)
tree317bcb0a30e7098865758e2e5936b1a014336449
parentdf9d271552339d13a874351204053beddf2801b1 (diff)
apalis-tk1: use mainline u-boot
Mainline (sources.denx.de) has all the functionality needed for Apalis TK1. Build directly from the mainline repo. Add a bbappend which makes the cboot image format. Related-to: ELB-4090 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--conf/machine/apalis-tk1.conf4
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc22
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend (renamed from recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb)14
3 files changed, 3 insertions, 37 deletions
diff --git a/conf/machine/apalis-tk1.conf b/conf/machine/apalis-tk1.conf
index 6b543a8..766eab0 100644
--- a/conf/machine/apalis-tk1.conf
+++ b/conf/machine/apalis-tk1.conf
@@ -38,8 +38,8 @@ WIC_CREATE_EXTRA_ARGS:append = " --no-fstab-update"
# The kernel lives in a seperate FAT or UBI partition, don't deploy it in /boot
RDEPENDS:${KERNEL_PACKAGE_NAME}-base = ""
-PREFERRED_PROVIDER_u-boot = "u-boot-toradex-tk1"
-PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex-tk1"
+PREFERRED_PROVIDER_u-boot = "u-boot"
+PREFERRED_PROVIDER_virtual/bootloader = "u-boot"
UBOOT_MACHINE = "apalis-tk1_defconfig"
UBOOT_ENTRYPOINT = "0"
UBOOT_LOADADDRESS = "0x80008000"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc b/recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc
deleted file mode 100644
index 3f71fc2..0000000
--- a/recipes-bsp/u-boot/u-boot-toradex-common-tk1.inc
+++ /dev/null
@@ -1,22 +0,0 @@
-HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
-SECTION = "bootloaders"
-DEPENDS += "flex-native bison-native"
-
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
-PE = "1"
-
-PV = "2020.07+git${SRCPV}"
-inherit toradex-u-boot-localversion
-
-# We use the revision in order to avoid having to fetch it from the
-# repo during parse
-SRCREV = "e4279843b222d170114a01eb4dca2b9f6515de61"
-SRCBRANCH = "toradex_2020.07"
-SRCREV:use-head-next = "${AUTOREV}"
-
-SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=https;branch=${SRCBRANCH}"
-
-S = "${WORKDIR}/git"
-
-UBOOT_INITIAL_ENV = "u-boot-initial-env"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb b/recipes-bsp/u-boot/u-boot_%.bbappend
index 7e772bf..fcd3a4d 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-tk1_2020.07.bb
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -1,27 +1,15 @@
-require u-boot-toradex-common-tk1.inc
-require recipes-bsp/u-boot/u-boot.inc
-
-B = "${WORKDIR}/build"
-
-DEPENDS += "bc-native dtc-native"
+FILESEXTRAPATHS:prepend := "${THISDIR}//files:"
DEPENDS:append:apalis-tk1 = " cbootimage-native"
-PROVIDES += "u-boot"
-
-COMPATIBLE_MACHINE = "(apalis-tk1)"
-
SRC_URI:append:apalis-tk1 = " \
file://apalis-tk1.img.cfg \
file://fw_env.config \
file://PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct \
"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
do_deploy:append:apalis-tk1() {
cd ${DEPLOYDIR}
cp ${WORKDIR}/PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct .
cbootimage -s tegra124 ${WORKDIR}/apalis-tk1.img.cfg apalis-tk1.img
rm PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.bct
}
-