summaryrefslogtreecommitdiff
path: root/recipes-bsp/alsa-state
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-01-29 12:37:47 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2013-01-29 12:37:47 +0100
commiteacf467022aaf28058f32f0ac326951296e7414a (patch)
tree65d311446a3073302ad43702699a8a0d7c2343df /recipes-bsp/alsa-state
parentea1470481bc31e0ed256c83052044d9fb6737092 (diff)
alsa: add Apalis-T30 initial asound.state
Diffstat (limited to 'recipes-bsp/alsa-state')
-rw-r--r--recipes-bsp/alsa-state/alsa-state.bbappend5
-rw-r--r--recipes-bsp/alsa-state/alsa-state/apalis-t30/asound.state147
2 files changed, 151 insertions, 1 deletions
diff --git a/recipes-bsp/alsa-state/alsa-state.bbappend b/recipes-bsp/alsa-state/alsa-state.bbappend
index 2065b80..057bd10 100644
--- a/recipes-bsp/alsa-state/alsa-state.bbappend
+++ b/recipes-bsp/alsa-state/alsa-state.bbappend
@@ -1,3 +1,6 @@
-PRINC = "6"
+PRINC = "7"
FILESEXTRAPATHS_prepend := "${THISDIR}/alsa-state/:"
+
+#make this machine specific, as we have different codecs with different settings
+PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/alsa-state/alsa-state/apalis-t30/asound.state b/recipes-bsp/alsa-state/alsa-state/apalis-t30/asound.state
new file mode 100644
index 0000000..b78aaff
--- /dev/null
+++ b/recipes-bsp/alsa-state/alsa-state/apalis-t30/asound.state
@@ -0,0 +1,147 @@
+state.colibrit30sgtl5 {
+ control.1 {
+ iface MIXER
+ name 'PCM Playback Volume'
+ value.0 126
+ value.1 126
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 192'
+ }
+ }
+ control.2 {
+ iface MIXER
+ name 'Capture Volume'
+ value.0 12
+ value.1 12
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 15'
+ }
+ }
+ control.3 {
+ iface MIXER
+ name 'Capture Attenuate Switch (-6dB)'
+ value 1
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 2'
+ dbmin -600
+ dbmax 600
+ dbvalue.0 0
+ }
+ }
+ control.4 {
+ iface MIXER
+ name 'Capture ZC Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.5 {
+ iface MIXER
+ name 'Headphone Playback Volume'
+ value.0 127
+ value.1 127
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 127'
+ dbmin -5150
+ dbmax 1200
+ dbvalue.0 1200
+ dbvalue.1 1200
+ }
+ }
+ control.6 {
+ iface MIXER
+ name 'Headphone Playback ZC Switch'
+ value true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 1
+ }
+ }
+ control.7 {
+ iface MIXER
+ name 'Mic Volume'
+ value 2
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 4'
+ dbmin 0
+ dbmax 4000
+ dbvalue.0 3000
+ }
+ }
+ control.8 {
+ iface MIXER
+ name 'Headphone Mux'
+ value DAC
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 DAC
+ item.1 LINE_IN
+ }
+ }
+ control.9 {
+ iface MIXER
+ name 'Capture Mux'
+ value MIC_IN
+ comment {
+ access 'read write'
+ type ENUMERATED
+ count 1
+ item.0 MIC_IN
+ item.1 LINE_IN
+ }
+ }
+ control.10 {
+ iface MIXER
+ name 'AVP alsa device select'
+ value 1
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 6'
+ }
+ }
+ control.11 {
+ iface MIXER
+ name 'AVP DMA channel id'
+ value -1
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - 32'
+ }
+ }
+ control.12 {
+ iface MIXER
+ name 'AVP DMA address'
+ value 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 1
+ range '0 - -1'
+ }
+ }
+}