summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2014-04-05 10:52:23 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2014-04-05 11:04:48 +0200
commit4e455569fbfad5157e53596db61f680712577dda (patch)
tree226662034c73888650151f9ec4a1c4c3811c3cbb /recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
parent18102c5436b283e82d51e2c0b194822152e29a95 (diff)
u-boot-fw-utils: provide matching recipes
With the change to our own u-boot recipes the bbappend to the common u-boot-fw-utils recipe is no longer a sane solution. While at it cleanup COMPATIBLE_MACHINE style.
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
new file mode 100644
index 0000000..5320f82
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "U-boot bootloader fw_printenv/setenv utils"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb \
+ file://README;beginline=1;endline=22;md5=5ba4218ac89af7846802d0348df3fb90"
+SECTION = "bootloader"
+PROVIDES = "u-boot-fw-utils"
+DEPENDS = "mtd-utils"
+
+COMPATIBLE_MACHINE = "(colibri-t20|colibri-t30|apalis-t30)"
+
+DEFAULT_PREFERENCE_colibri-t20 = "1"
+DEFAULT_PREFERENCE_colibri-t30 = "1"
+DEFAULT_PREFERENCE_apalis-t30 = "1"
+
+FILESPATHPKG =. "git:"
+S="${WORKDIR}/git"
+SRC_URI_COLIBRI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
+SRC_URI_COLIBRI += "file://u-boot-dont-build-standalone.patch"
+# This revision is based on upstream "v2011.06"
+SRCREV_COLIBRI = "ccd521c4681a5850bbec1feec140eeaec33936b0"
+
+PV_colibri-t20 = "${PR}+gitr${SRCREV}"
+PV_colibri-t30 = "${PR}+gitr${SRCREV}"
+PV_apalis-t30 = "${PR}+gitr${SRCREV}"
+
+SRC_URI_colibri-t20 = "${SRC_URI_COLIBRI}"
+SRC_URI_colibri-t30 = "${SRC_URI_COLIBRI}"
+SRC_URI_apalis-t30 = "${SRC_URI_COLIBRI}"
+
+SRCREV_colibri-t20 = "${SRCREV_COLIBRI}"
+SRCREV_colibri-t30 = "${SRCREV_COLIBRI}"
+SRCREV_apalis-t30 = "${SRCREV_COLIBRI}"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTSTRIP="true"'
+
+inherit uboot-config
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake env
+}
+
+do_install () {
+ install -d ${D}${base_sbindir}
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"