summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2016-07-21 18:40:17 -0700
committerDominik Sliwa <dominik.sliwa@toradex.com>2016-08-17 14:08:52 +0200
commit838ea9bf30fda85fa64e02d438d9a9e0ce749409 (patch)
treee868d524343a96d1cbdbb242912f97b63cdf681b /recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
parenta51f93cb530a05478e559ae5d6fd0ca3bd91a134 (diff)
u-boot-fw-utils: use negative offset for environment
Rely on newly implemented configuration functionality to locate the environment at the end of the boot partition. Signed-off-by: Stefan Agner <stefan.agner@toradex.com> Acked-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb30
1 files changed, 2 insertions, 28 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
index f9b9f3d..649f4fc 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fw-utils_git.bb
@@ -15,8 +15,8 @@ DEFAULT_PREFERENCE_colibri-t30 = "1"
FILESPATHPKG =. "git:"
S="${WORKDIR}/git"
# This revision is based on upstream "v2015.04"
-SRCREV = "10bc451b6948e842e24799fe7fb037d335714b36"
-SRCBRANCH = "2015.04-toradex"
+SRCREV = "476fa4400d2cc32279c7ae7e73e7c4ab1bff4327"
+SRCBRANCH = "2015.04-toradex-next"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH} \
file://fw_env.config \
"
@@ -70,30 +70,4 @@ pkg_postinst_${PN}_colibri-t20 () {
grep u-boot-env /proc/mtd | awk '{print "/dev/" substr($1,0,4) " 0x00000000 0x00010000 0x" $3 " 1" >> "/etc/fw_env.config" }'
}
-pkg_postinst_${PN}_tegra3 () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
- # Environment in eMMC, before the configblock at the end of 1st "boot sector"
- DISK="mmcblk0boot0"
- DISK_SIZE=`cat /sys/block/$DISK/size`
- CONFIG_ENV_SIZE=8192 # 0x2000
- CONFIG_ENV_OFFSET=`expr $DISK_SIZE \* 512 - $CONFIG_ENV_SIZE - 512`
- printf "/dev/%s\t0x%X\t0x%X\n" $DISK $CONFIG_ENV_OFFSET $CONFIG_ENV_SIZE >> "/etc/fw_env.config"
-}
-
-pkg_postinst_${PN}_tegra124 () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
- # Environment in eMMC, before the configblock at the end of 1st "boot sector"
- DISK="mmcblk0boot0"
- DISK_SIZE=`cat /sys/block/$DISK/size`
- CONFIG_ENV_SIZE=8192 # 0x2000
- CONFIG_ENV_OFFSET=`expr $DISK_SIZE \* 512 - $CONFIG_ENV_SIZE - 512`
- printf "/dev/%s\t0x%X\t0x%X\n" $DISK $CONFIG_ENV_OFFSET $CONFIG_ENV_SIZE >> "/etc/fw_env.config"
-}
-
PACKAGE_ARCH = "${MACHINE_ARCH}"