summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-03-05 12:11:15 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-04-07 12:13:53 +0200
commitf61bd19b4bafbe5bc51efaa3879c274e4fc0d36b (patch)
treee092e4ebbe16282a7358c221be72173d03c88aa2 /recipes-kernel/linux
parentab40b01c98a3c431048233e2716f705355f4c6e9 (diff)
linux-toradex_git: suppress kernel too old warning
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-toradex_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex_git.bb b/recipes-kernel/linux/linux-toradex_git.bb
index 051cf03..aad0307 100644
--- a/recipes-kernel/linux/linux-toradex_git.bb
+++ b/recipes-kernel/linux/linux-toradex_git.bb
@@ -49,3 +49,17 @@ do_configure_prepend () {
do_uboot_mkimage_prepend () {
cd ${B}
}
+
+# glibc 2.24 set the oldest kernel to 3.2.0, however the downstream L4T 3.1.10
+# kernel provides all needed interfaces, so override the check_oldest_kernel to
+# disable the warning
+python check_oldest_kernel() {
+ oldest_kernel = d.getVar('OLDEST_KERNEL', True)
+ kernel_version = "3.2.0"
+ tclibc = d.getVar('TCLIBC', True)
+ if tclibc == 'glibc':
+ kernel_version = kernel_version.split('-', 1)[0]
+ if oldest_kernel and kernel_version:
+ if bb.utils.vercmp_string(kernel_version, oldest_kernel) < 0:
+ bb.warn('%s: OLDEST_KERNEL is "%s" but the version of the kernel you are building is "%s" - therefore %s as built may not be compatible with this kernel. Either set OLDEST_KERNEL to an older version, or build a newer kernel.' %(d.getVar('PN', True), oldest_kernel, kernel_version, tclibc))
+}