summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-12-01 15:40:30 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-01-11 12:03:36 +0100
commitcf0db22dbfb5e558625f4db303a68d765bee7a99 (patch)
treee5d8866b7aaa199397cf955937dca802c247268e /recipes-kernel
parent13409623191e4150fc7db661a7238897d416cad0 (diff)
linux-toradex_3.10.40: drop own compile implementation
The regular implementation works. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex_3.10.40.bb19
1 files changed, 0 insertions, 19 deletions
diff --git a/recipes-kernel/linux/linux-toradex_3.10.40.bb b/recipes-kernel/linux/linux-toradex_3.10.40.bb
index 5ead79f..5d05252 100644
--- a/recipes-kernel/linux/linux-toradex_3.10.40.bb
+++ b/recipes-kernel/linux/linux-toradex_3.10.40.bb
@@ -50,25 +50,6 @@ do_configure_prepend () {
printf "%s%s" +g $head > ${S}/.scmversion
}
-kernel_do_compile() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
- export CC="`echo "${KERNEL_CC}" | sed 's/-mfloat-abi=hard//g'`"
- oe_runmake ${KERNEL_IMAGETYPE_FOR_MAKE} ${KERNEL_ALT_IMAGETYPE} LD="${KERNEL_LD}"
- if test "${KERNEL_IMAGETYPE_FOR_MAKE}.gz" = "${KERNEL_IMAGETYPE}"; then
- gzip -9c < "${KERNEL_IMAGETYPE_FOR_MAKE}" > "${KERNEL_OUTPUT}"
- fi
-}
-
-do_compile_kernelmodules() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
- export CC="`echo "${KERNEL_CC}" | sed 's/-mfloat-abi=hard//g'`"
- if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
- oe_runmake ${PARALLEL_MAKE} modules LD="${KERNEL_LD}"
- else
- bbnote "no modules to compile"
- fi
-}
-
do_uboot_mkimage_prepend() {
cd ${B}
mkdir -p ${B}/arch/${ARCH}/boot/ || true