summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-07-15 15:46:59 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-07-15 15:48:26 +0200
commitb47dad6cf9bd5be5287dac3835ea037a2fd30cf7 (patch)
treede95b549d54d590646cb9031070205928f5d0021
parent8acd4b9cd0c41261813bd7d8b060ad313a63d519 (diff)
vnc: add directvnc and tightvnc recipesV2.2
Two popular VNC clients: - DirectVNC based on DirectFB (e.g. without X11) - TightVNC based on X11 (cherry picked from commit ef4113208de357a5b8accd7610f8bf3230125a59)
-rw-r--r--recipes-graphics/vnc/directvnc_0.7.8.bb13
-rw-r--r--recipes-graphics/vnc/tightvnc/Makefile24
-rw-r--r--recipes-graphics/vnc/tightvnc/Vncviewer66
-rw-r--r--recipes-graphics/vnc/tightvnc_1.3.10.bb43
4 files changed, 146 insertions, 0 deletions
diff --git a/recipes-graphics/vnc/directvnc_0.7.8.bb b/recipes-graphics/vnc/directvnc_0.7.8.bb
new file mode 100644
index 0000000..ff3196b
--- /dev/null
+++ b/recipes-graphics/vnc/directvnc_0.7.8.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "DirectVNC provides a very thin VNC client for unix framebuffer systems."
+HOMEPAGE = "http://drinkmilk.github.com/directvnc/"
+SECTION = "utils"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
+
+DEPENDS = "zlib libpng jpeg directfb xproto"
+
+SRC_URI = "https://github.com/downloads/drinkmilk/directvnc/directvnc-${PV}.tar.gz"
+SRC_URI[md5sum] = "063f9d98956006f230dcbc05f822525b"
+SRC_URI[sha256sum] = "07d6109aef5bba2df86f0dd658be7ed9d828801be0878eba3d32f041189d3330"
+
+inherit autotools
diff --git a/recipes-graphics/vnc/tightvnc/Makefile b/recipes-graphics/vnc/tightvnc/Makefile
new file mode 100644
index 0000000..3f720f8
--- /dev/null
+++ b/recipes-graphics/vnc/tightvnc/Makefile
@@ -0,0 +1,24 @@
+OBJS = argsresources.o \
+caps.o \
+colour.o \
+cursor.o \
+desktop.o \
+dialogs.o \
+fullscreen.o \
+listen.o \
+misc.o \
+popup.o \
+rfbproto.o \
+selection.o \
+shm.o \
+sockets.o \
+tunnel.o \
+vncviewer.o \
+../libvncauth/vncauth.o \
+../libvncauth/d3des.o
+
+tightvncviewer : $(OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -lX11 -lXaw6 -ljpeg -lz -lXt -lXmu -lXext -o tightvncviewer
+
+%.o: %.c Makefile
+ $(CC) -c $(CFLAGS) -I. -I../include -I../libvncauth/ -o $@ $<
diff --git a/recipes-graphics/vnc/tightvnc/Vncviewer b/recipes-graphics/vnc/tightvnc/Vncviewer
new file mode 100644
index 0000000..ed60ecd
--- /dev/null
+++ b/recipes-graphics/vnc/tightvnc/Vncviewer
@@ -0,0 +1,66 @@
+Vncviewer.title: TightVNC: %s
+Vncviewer.translations:\
+ <Enter>: SelectionToVNC()\n\
+ <Leave>: SelectionFromVNC()
+*form.background: black
+*viewport.allowHoriz: True
+*viewport.allowVert: True
+*viewport.useBottom: True
+*viewport.useRight: True
+*viewport*Scrollbar*thumb: None
+*desktop.baseTranslations:\
+ <Key>F8: ShowPopup()\n\
+ <ButtonPress>: SendRFBEvent()\n\
+ <ButtonRelease>: SendRFBEvent()\n\
+ <Motion>: SendRFBEvent()\n\
+ <KeyPress>: SendRFBEvent()\n\
+ <KeyRelease>: SendRFBEvent()
+*serverDialog.dialog.label: VNC server:
+*serverDialog.dialog.value:
+*serverDialog.dialog.value.translations: #override\n\
+ <Key>Return: ServerDialogDone()
+*passwordDialog.dialog.label: Password:
+*passwordDialog.dialog.value:
+*passwordDialog.dialog.value.AsciiSink.echo: False
+*passwordDialog.dialog.value.translations: #override\n\
+ <Key>Return: PasswordDialogDone()
+*popup.title: TightVNC popup
+*popup*background: grey
+*popup*font: -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
+*popup.buttonForm.Command.borderWidth: 0
+*popup.buttonForm.Toggle.borderWidth: 0
+*popup.translations: #override <Message>WM_PROTOCOLS: HidePopup()
+*popup.buttonForm.translations: #override\n\
+ <KeyPress>: SendRFBEvent() HidePopup()
+*popupButtonCount: 8
+*popup*button1.label: Dismiss popup
+*popup*button1.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: HidePopup()
+*popup*button2.label: Quit viewer
+*popup*button2.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: Quit()
+*popup*button3.label: Full screen
+*popup*button3.type: toggle
+*popup*button3.translations: #override\n\
+ <Visible>: SetFullScreenState()\n\
+ <Btn1Down>,<Btn1Up>: toggle() HidePopup() ToggleFullScreen()
+*popup*button4.label: Clipboard: local -> remote
+*popup*button4.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: SelectionToVNC(always) HidePopup()
+*popup*button5.label: Clipboard: local <- remote
+*popup*button5.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: SelectionFromVNC(always) HidePopup()
+*popup*button6.label: Request refresh
+*popup*button6.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: SendRFBEvent(fbupdate) HidePopup()
+*popup*button7.label: Send ctrl-alt-del
+*popup*button7.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: SendRFBEvent(keydown,Control_L)\
+ SendRFBEvent(keydown,Alt_L)\
+ SendRFBEvent(key,Delete)\
+ SendRFBEvent(keyup,Alt_L)\
+ SendRFBEvent(keyup,Control_L)\
+ HidePopup()
+*popup*button8.label: Send F8
+*popup*button8.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: SendRFBEvent(key,F8) HidePopup()
diff --git a/recipes-graphics/vnc/tightvnc_1.3.10.bb b/recipes-graphics/vnc/tightvnc_1.3.10.bb
new file mode 100644
index 0000000..39297a0
--- /dev/null
+++ b/recipes-graphics/vnc/tightvnc_1.3.10.bb
@@ -0,0 +1,43 @@
+DESCRIPTION-${PN}-viewer = "A lightweight VNC viewer"
+HOMEPAGE = "http://www.tightvnc.com/"
+SECTION = "utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://../LICENCE.TXT;md5=75b02c2872421380bbd47781d2bd75d3"
+
+DEPENDS = "virtual/libx11 zlib libxmu libxaw jpeg libxt libxext libxmu"
+
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/vnc-tight/${PN}-${PV}_unixsrc.tar.bz2 \
+ file://Makefile \
+ file://Vncviewer"
+
+S = "${WORKDIR}/vnc_unixsrc/vncviewer/"
+
+PACKAGES = "${PN}-viewer-dbg ${PN}-viewer"
+FILES_${PN}-viewer-dbg = "${bindir}/.debug"
+FILES_${PN}-viewer = "${bindir}/${PN}viewer ${sysconfdir}"
+
+do_compile () {
+ install ${WORKDIR}/Makefile ${S}
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install ${PN}viewer ${D}${bindir}
+ install -d ${D}${sysconfdir}/X11/app-defaults
+ install -m 644 ${WORKDIR}/Vncviewer ${D}${sysconfdir}/X11/app-defaults/Vncviewer
+}
+
+pkg_postinst_${PN}-viewer () {
+ update-alternatives --install ${bindir}/vncviewer vncviewer tightvncviewer 100
+}
+
+
+pkg_prerm_${PN}-viewer () {
+ update-alternatives --remove ${bindir}/vncviewer vncviewer tightvncviewer 100
+}
+
+SRC_URI[md5sum] = "397b35faad32d5246b6d44b142f8304f"
+SRC_URI[sha256sum] = "f48c70fea08d03744ae18df6b1499976362f16934eda3275cead87baad585c0d"