summaryrefslogtreecommitdiff
path: root/drivers/staging/usbip/userspace/libsrc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/staging/usbip/userspace/libsrc/Makefile.am')
-rw-r--r--drivers/staging/usbip/userspace/libsrc/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/drivers/staging/usbip/userspace/libsrc/Makefile.am b/drivers/staging/usbip/userspace/libsrc/Makefile.am
new file mode 100644
index 000000000000..77ecf6b844b7
--- /dev/null
+++ b/drivers/staging/usbip/userspace/libsrc/Makefile.am
@@ -0,0 +1,7 @@
+libusbip_la_CPPFLAGS := -DUSBIDS_FILE='"@USBIDS_DIR@/usb.ids"'
+libusbip_la_CFLAGS := @EXTRA_CFLAGS@
+libusbip_la_LDFLAGS := -version-info @LIBUSBIP_VERSION@
+
+lib_LTLIBRARIES := libusbip.la
+libusbip_la_SOURCES := names.c names.h stub_driver.c stub_driver.h usbip.h \
+ usbip_common.c usbip_common.h vhci_driver.c vhci_driver.h