summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2015-01-03 14:34:55 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2015-01-10 16:31:55 +0100
commit01532ddae3fac945ba9b58df2fa34249ba4b8546 (patch)
treeac8a7954f494f3378e65dc0c6dd8fc473e2afdb4
parent0f96c5c61018de220a4ed8c5e5832afcb7c894c9 (diff)
libfm: update to 1.2.3
Patch is sent to the oe-core layer. As this will not make it into dizzy add it here until we have it available from openembedded/meta.
-rw-r--r--recipes-lxde/libfm/libfm-extra_1.2.3.bb21
-rw-r--r--recipes-lxde/libfm/libfm_1.2.3.bb36
2 files changed, 57 insertions, 0 deletions
diff --git a/recipes-lxde/libfm/libfm-extra_1.2.3.bb b/recipes-lxde/libfm/libfm-extra_1.2.3.bb
new file mode 100644
index 0000000..8bdb12c
--- /dev/null
+++ b/recipes-lxde/libfm/libfm-extra_1.2.3.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Library for file management"
+HOMEPAGE = "http://pcmanfm.sourceforge.net/"
+
+LICENSE = "LGPLv2+"
+LIC_FILES_CHKSUM = "file://src/fm-extra.h;beginline=8;endline=21;md5=ef1f84da64b3c01cca447212f7ef6007"
+
+SECTION = "x11/libs"
+DEPENDS = "glib-2.0 intltool-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/libfm-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "3ff38200701658f7e80e25ed395d92dd"
+SRC_URI[sha256sum] = "c692f1624a4cbc8d1dd55f3b3f3369fbf5d26f63a916e2c295230b2344e1fbf9"
+
+S = "${WORKDIR}/libfm-${PV}"
+
+EXTRA_OECONF = "--with-extra-only --with-gtk=no"
+
+inherit autotools-brokensep pkgconfig gtk-doc
+
+do_configure[dirs] =+ "${S}/m4"
diff --git a/recipes-lxde/libfm/libfm_1.2.3.bb b/recipes-lxde/libfm/libfm_1.2.3.bb
new file mode 100644
index 0000000..d5d4186
--- /dev/null
+++ b/recipes-lxde/libfm/libfm_1.2.3.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Library for file management"
+HOMEPAGE = "http://pcmanfm.sourceforge.net/"
+
+LICENSE = "GPLv2+ & LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
+ file://src/fm.h;beginline=8;endline=21;md5=ef1f84da64b3c01cca447212f7ef6007 \
+ file://src/base/fm-config.h;beginline=10;endline=23;md5=ef1f84da64b3c01cca447212f7ef6007 \
+ file://src/fm-gtk.h;beginline=6;endline=19;md5=646baa4955c04fe768f2ca27b92ac8dd"
+
+
+SECTION = "x11/libs"
+DEPENDS = "glib-2.0 pango gtk+ menu-cache intltool-native libexif libfm-extra"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/libfm-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "3ff38200701658f7e80e25ed395d92dd"
+SRC_URI[sha256sum] = "c692f1624a4cbc8d1dd55f3b3f3369fbf5d26f63a916e2c295230b2344e1fbf9"
+
+inherit autotools-brokensep pkgconfig gtk-doc
+
+do_configure[dirs] =+ "${S}/m4"
+
+PACKAGES += "${PN}-mime"
+FILES_${PN}-mime = "${datadir}/mime/"
+FILES_${PN}-dbg += "${libdir}/libfm/modules/.debug"
+
+do_install_append () {
+ # remove files which are part of libfm-extra
+ rm -f ${D}/usr/include/libfm-1.0/fm-xml-file.h
+ rm -f ${D}/usr/include/libfm-1.0/fm-version.h
+ rm -f ${D}/usr/include/libfm-1.0/fm-extra.h
+ rm -f ${D}/usr/lib/pkgconfig/libfm-extra.pc
+ rm -f ${D}/usr/lib/libfm-extra.so*
+ rm -f ${D}/usr/lib/libfm-extra.a
+ rm -f ${D}/usr/lib/libfm-extra.la
+}