summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-02-02 13:40:30 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2020-02-02 16:08:32 +0100
commitddf211018f84af51909353ae9582b76fab35731c (patch)
treedae147329b44ec2a0c328562fbb1239f1e3a1561
parente0bdbadc0c476eff9fd50f5679c15d77429a2b07 (diff)
core-image-lxde: add a core image
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-lxde/images/core-image-lxde.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-lxde/images/core-image-lxde.bb b/recipes-lxde/images/core-image-lxde.bb
new file mode 100644
index 0000000..3356f8c
--- /dev/null
+++ b/recipes-lxde/images/core-image-lxde.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Image with the LXDE desktop environment"
+export IMAGE_BASENAME = "core-image-lxde"
+
+LICENSE = "MIT"
+
+# Most LXDE components don't even compile without native X11 support,
+# (gdk-x11), so make this fail early if x11 is provided by XWAYLAND.
+inherit features_check
+REQUIRED_DISTRO_FEATURES = "x11"
+CONFLICT_DISTRO_FEATURES = "wayland"
+
+SYSTEMD_DEFAULT_TARGET = "graphical.target"
+
+IMAGE_LINGUAS = " "
+
+IMAGE_INSTALL += " \
+ packagegroup-core-boot \
+ packagegroup-core-x11 \
+ packagegroup-lxde-extended \
+ kernel-modules \
+ \
+ lxdm \
+ \
+ openbox \
+ openbox-theme-clearlooks \
+ openbox-theme-onyx \
+ obconf \
+ hicolor-icon-theme \
+"
+
+IMAGE_DEV_MANAGER = "udev"
+IMAGE_INIT_MANAGER = "systemd"
+IMAGE_INITSCRIPTS = " "
+IMAGE_LOGIN_MANAGER = "busybox shadow"
+
+inherit core-image