summaryrefslogtreecommitdiff
path: root/recipes-lxde/lxappearance/lxappearance-0.5.2
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-lxde/lxappearance/lxappearance-0.5.2')
-rw-r--r--recipes-lxde/lxappearance/lxappearance-0.5.2/empty-cursor.patch12
-rw-r--r--recipes-lxde/lxappearance/lxappearance-0.5.2/lxappearance_missing_am_prog_cc_c_o.patch10
2 files changed, 22 insertions, 0 deletions
diff --git a/recipes-lxde/lxappearance/lxappearance-0.5.2/empty-cursor.patch b/recipes-lxde/lxappearance/lxappearance-0.5.2/empty-cursor.patch
new file mode 100644
index 0000000..381c8be
--- /dev/null
+++ b/recipes-lxde/lxappearance/lxappearance-0.5.2/empty-cursor.patch
@@ -0,0 +1,12 @@
+diff -auNr lxappearance-0.5.1.orig/src/cursor-theme.c lxappearance-0.5.1/src/cursor-theme.c
+--- lxappearance-0.5.1.orig/src/cursor-theme.c 2012-01-15 20:16:51.113223420 +0100
++++ lxappearance-0.5.1/src/cursor-theme.c 2012-01-15 20:17:17.017897756 +0100
+@@ -44,6 +44,8 @@
+ cursor = gdk_cursor_new(types[i]);
+ GdkPixbuf* pix = gdk_cursor_get_image(cursor);
+ gdk_cursor_unref(cursor);
++ if (pix == NULL)
++ continue;
+ gtk_list_store_insert_with_values(store, &it, -1, 0, pix, -1);
+ g_object_unref(pix);
+ }
diff --git a/recipes-lxde/lxappearance/lxappearance-0.5.2/lxappearance_missing_am_prog_cc_c_o.patch b/recipes-lxde/lxappearance/lxappearance-0.5.2/lxappearance_missing_am_prog_cc_c_o.patch
new file mode 100644
index 0000000..6d76a18
--- /dev/null
+++ b/recipes-lxde/lxappearance/lxappearance-0.5.2/lxappearance_missing_am_prog_cc_c_o.patch
@@ -0,0 +1,10 @@
+--- lxappearance-0.5.1/configure.ac~ 2011-07-29 16:50:18.000000000 +0200
++++ lxappearance-0.5.1/configure.ac 2012-08-12 16:52:52.000000000 +0200
+@@ -16,6 +16,7 @@
+
+ # Checks for programs.
+ AC_PROG_CC
++AM_PROG_CC_C_O
+ # AM_PROG_LIBTOOL
+
+ # Checks for libraries.