summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2021-03-25 12:57:09 +0100
committerMing Liu <ming.liu@toradex.com>2021-03-25 13:05:27 +0100
commitefbdc6e55cbcd49c576c7c8da2b6dd55e200b6d1 (patch)
treec4fa6aa2de6991a577f32d2afa49b24e3119be8d
parente38615820b4fd86484effd75d486b326d6f4e6e3 (diff)
tezi-metadata: set SSTATE_DUPWHITELIST
We want to always check the latest EULA file in image_type_tezi.bbclass So we put LA_OPT_NXP_SW.html to sstate duplicate whitelist, this ensures it could be deployed to ${DEPLOY_DIR_IMAGE} as a backup even it's aleady existed. This fixes a following bitbake error: | ERROR: tezi-metadata-0.3-r0 do_deploy: The recipe tezi-metadata is | trying to install files into a shared area when those files already | exist. Those files and their manifest location are: | images/colibri-imx8x-v10b/LA_OPT_NXP_SW.html | (not matched to any task) | Please verify which recipe should provide the above files. Related-to: ELB-3485 Signed-off-by: Ming Liu <ming.liu@toradex.com>
-rw-r--r--recipes-bsp/tezi-metadata/tezi-metadata_0.3.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-bsp/tezi-metadata/tezi-metadata_0.3.bb b/recipes-bsp/tezi-metadata/tezi-metadata_0.3.bb
index eef6d06..50149f9 100644
--- a/recipes-bsp/tezi-metadata/tezi-metadata_0.3.bb
+++ b/recipes-bsp/tezi-metadata/tezi-metadata_0.3.bb
@@ -10,6 +10,12 @@ SRC_URI = " \
file://LA_OPT_NXP_SW.html \
"
+# We want to always check the latest EULA file in image_type_tezi.bbclass
+# So we put LA_OPT_NXP_SW.html to sstate duplicate whitelist, this
+# ensures it could be deployed to ${DEPLOY_DIR_IMAGE} as a backup even
+# it's aleady existed.
+SSTATE_DUPWHITELIST_prepend = "${DEPLOY_DIR_IMAGE}/LA_OPT_NXP_SW.html "
+
inherit deploy nopackages
do_deploy () {