summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefano Viola <stefano.viola@toradex.com>2022-11-23 00:22:35 +0100
committerStefano Viola <stefano.viola@toradex.com>2022-11-25 08:41:47 +0000
commit15ec9fe118984cc977016269c069571c4530ef8f (patch)
tree5ad5dd3e78319a89f5214da4ceec031c10df4726
parent8be201d9c8b79dc90b9a22cb73094f11ac854305 (diff)
u-boot-toradex_2022.07: improve deploy of u-boot-with-spl.imx
The u-boot-with-spl.imx binary, now is deployed for each u-boot configuration type and the condition that suppressed the error in case u-boot-with-spl.imx was not generated has been removed. Signed-off-by: Stefano Viola <stefano.viola@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2022.07.bb24
1 files changed, 19 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb b/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb
index dcf7fff..b343eb7 100644
--- a/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb
@@ -50,11 +50,25 @@ nand_padding () {
}
deploy_uboot_with_spl () {
- for config in ${UBOOT_MACHINE}; do
- if [ -f "${B}/${config}/u-boot-with-spl.imx" ]; then
- install -D -m 644 ${B}/${config}/u-boot-with-spl.imx ${DEPLOYDIR}/u-boot-with-spl.imx
- fi
- done
+ #Deploy u-boot-with-spl.imx
+ if [ -n "${UBOOT_CONFIG}" ]
+ then
+ for config in ${UBOOT_MACHINE}; do
+ i=$(expr $i + 1);
+ for type in ${UBOOT_CONFIG}; do
+ j=$(expr $j + 1);
+ if [ $j -eq $i ]
+ then
+ install -D -m 644 ${B}/${config}/u-boot-with-spl.imx ${DEPLOYDIR}/u-boot-with-spl.imx-${MACHINE}-${type}
+ ln -sf u-boot-with-spl.imx-${MACHINE}-${type} ${DEPLOYDIR}/u-boot-with-spl.imx
+ fi
+ done
+ unset j
+ done
+ unset i
+ else
+ install -D -m 644 ${B}/${config}/u-boot-with-spl.imx ${DEPLOYDIR}/u-boot-with-spl.imx
+ fi
}
# build imx-boot from within U-Boot