summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2023-01-21 13:36:59 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2023-01-21 13:38:41 +0100
commit6958f9cd02336bbf1e608206675a03b1a229a792 (patch)
tree903dcf255cb5aba12212471b85eb0fa2b51fa067
parentb88aaa111f1362a8d01ee411aaa1399625a9b8b2 (diff)
linux-toradex-mainline-rt: patch nand flash size cells
Revert a patch which makes the mtd parsing of the dtb node as added by U-Boot fail. Related-to: ELB-4930 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-ARM-dts-imx7-Fix-NAND-controller-size-cells.patch49
-rw-r--r--recipes-kernel/linux/linux-toradex-mainline-rt_git.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-ARM-dts-imx7-Fix-NAND-controller-size-cells.patch b/recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-ARM-dts-imx7-Fix-NAND-controller-size-cells.patch
new file mode 100644
index 0000000..481b038
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex-mainline-git/0001-Revert-ARM-dts-imx7-Fix-NAND-controller-size-cells.patch
@@ -0,0 +1,49 @@
+From df86f83dd8e191c518ef88ee6619b4ceb164e726 Mon Sep 17 00:00:00 2001
+From: Francesco Dolcini <francesco.dolcini@toradex.com>
+Date: Mon, 5 Dec 2022 16:23:27 +0100
+Subject: [PATCH] Revert "ARM: dts: imx7: Fix NAND controller size-cells"
+
+upstream commit ef19964da8a668c683f1d38274f6fb756e047945
+
+This reverts commit 753395ea1e45c724150070b5785900b6a44bd5fb.
+
+It introduced a boot regression on colibri-imx7, and potentially any
+other i.MX7 boards with MTD partition list generated into the fdt by
+U-Boot.
+
+While the commit we are reverting here is not obviously wrong, it fixes
+only a dt binding checker warning that is non-functional, while it
+introduces a boot regression and there is no obvious fix ready.
+
+Fixes: 753395ea1e45 ("ARM: dts: imx7: Fix NAND controller size-cells")
+Signed-off-by: Francesco Dolcini <francesco.dolcini@toradex.com>
+Reviewed-by: Miquel Raynal <miquel.raynal@bootlin.com>
+Acked-by: Marek Vasut <marex@denx.de>
+Cc: stable@vger.kernel.org
+Link: https://lore.kernel.org/all/Y4dgBTGNWpM6SQXI@francesco-nb.int.toradex.com/
+Link: https://lore.kernel.org/all/20221205144917.6514168a@xps-13/
+Signed-off-by: Arnd Bergmann <arnd@arndb.de>
+---
+ arch/arm/boot/dts/imx7s.dtsi | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/arch/arm/boot/dts/imx7s.dtsi b/arch/arm/boot/dts/imx7s.dtsi
+index 03d2e8544a4e..0fc9e6b8b05d 100644
+--- a/arch/arm/boot/dts/imx7s.dtsi
++++ b/arch/arm/boot/dts/imx7s.dtsi
+@@ -1270,10 +1270,10 @@ dma_apbh: dma-apbh@33000000 {
+ clocks = <&clks IMX7D_NAND_USDHC_BUS_RAWNAND_CLK>;
+ };
+
+- gpmi: nand-controller@33002000 {
++ gpmi: nand-controller@33002000{
+ compatible = "fsl,imx7d-gpmi-nand";
+ #address-cells = <1>;
+- #size-cells = <0>;
++ #size-cells = <1>;
+ reg = <0x33002000 0x2000>, <0x33004000 0x4000>;
+ reg-names = "gpmi-nand", "bch";
+ interrupts = <GIC_SPI 14 IRQ_TYPE_LEVEL_HIGH>;
+--
+2.35.3
+
diff --git a/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb b/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
index 5d4f1c1..8fa4f5f 100644
--- a/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
+++ b/recipes-kernel/linux/linux-toradex-mainline-rt_git.bb
@@ -13,4 +13,5 @@ SRCREV_machine:use-head-next = "${AUTOREV}"
SRC_URI:append = " \
file://preempt-rt.scc \
file://preempt-rt-less-latency.scc \
+ file://0001-Revert-ARM-dts-imx7-Fix-NAND-controller-size-cells.patch \
"