summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-08-29 14:02:28 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2022-08-29 14:05:09 +0200
commit7ad862bbbaaf4d912684c7634b45f68ad0feb400 (patch)
treeba32caf1a51d58ea733d9c52c4fe4685eecf7815
parent4f16c57dda5f49cef1648ba829d9bf10cb4010dc (diff)
u-boot: convert bbappend into our own recipe
The version mismatch between what we want to build and what the recipe in openembedded-core builds can get big so that CVE backports and other changes makes our build fail. Rather create our own recipe reusing the include file from openembedded-core to reduce the risk of build failures. Relates-to: ELB-4680 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex_2022.07.bb (renamed from recipes-bsp/u-boot/u-boot_%.bbappend)7
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb
index ed44612..ce260c9 100644
--- a/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/recipes-bsp/u-boot/u-boot-toradex_2022.07.bb
@@ -1,7 +1,8 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+require recipes-bsp/u-boot/u-boot-common.inc
+require recipes-bsp/u-boot/u-boot.inc
-# See commit fba0882bcd ("Add valgrind headers to U-Boot")
LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1"
+DEPENDS += "bc-native dtc-native python3-setuptools-native"
# hash of release v2022.07"
PV = "2022.07"
@@ -30,8 +31,6 @@ SRC_URI:append = " ${TDX_PATCHES}"
SRC_URI:append:use-nxp-bsp:colibri-imx7 = " \
file://0001-colibri_imx7-boot-linux-kernel-in-secure-mode.patch \
"
-# allready applied in 2022.07
-SRC_URI:remove = "file://0001-i2c-fix-stack-buffer-overflow-vulnerability-in-i2c-m.patch"
inherit toradex-u-boot-localversion