summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2017-08-15 18:38:01 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2017-12-22 02:00:13 +0100
commit6e4938ecc83e84e490fab7d014a6d56f0b9d37ed (patch)
treed288f7cc7b978d02e9e117414048abda940b7292
parent1930720250f7d0eb2cafff98da9d78b224a8953c (diff)
snapd: make the go build verbose
As OE generally hides the build output from the console it does not clutter the screen, however if something goes wrong the log file contains important debug info. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-support/snapd/snapd_2.25.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-support/snapd/snapd_2.25.bb b/recipes-support/snapd/snapd_2.25.bb
index 8ea3364..1923e8a 100644
--- a/recipes-support/snapd/snapd_2.25.bb
+++ b/recipes-support/snapd/snapd_2.25.bb
@@ -52,7 +52,7 @@ do_compile() {
ln -sf ${S} ${STAGING_LIBDIR}/${TARGET_SYS}/go/src/github.com/snapcore/snapd
for d in snap snapd snap-exec snapctl; do
- GOPATH=${STAGING_LIBDIR}/${TARGET_SYS}/go go build github.com/snapcore/snapd/cmd/$d
+ GOPATH=${STAGING_LIBDIR}/${TARGET_SYS}/go go build -x github.com/snapcore/snapd/cmd/$d
done
oe_runmake