summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Sliwa <dominik.sliwa@toradex.com>2018-05-24 15:00:08 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2018-06-18 14:46:30 +0200
commit950b67b29ce7dd9174efab80e1df6c5c4f0cbf3e (patch)
treee8e4457b395cd06ecaa3debddd8e6f8a2f4181b3
parent99f5f60097e010b0fc28809a9bd78124798b77bc (diff)
mwifiex: mwifiex module options
Add module load options for MWiFiEx driver, so the driver will create both uAP and station interfaces on boot. Signed-off-by: Dominik Sliwa <dominik.sliwa@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-bsp/mwifiexap/mwifiexap/mwifiex.conf1
-rw-r--r--recipes-bsp/mwifiexap/mwifiexap_1.0.bb17
2 files changed, 18 insertions, 0 deletions
diff --git a/recipes-bsp/mwifiexap/mwifiexap/mwifiex.conf b/recipes-bsp/mwifiexap/mwifiexap/mwifiex.conf
new file mode 100644
index 0000000..ccbeae4
--- /dev/null
+++ b/recipes-bsp/mwifiexap/mwifiexap/mwifiex.conf
@@ -0,0 +1 @@
+options mwifiex driver_mode=0x3
diff --git a/recipes-bsp/mwifiexap/mwifiexap_1.0.bb b/recipes-bsp/mwifiexap/mwifiexap_1.0.bb
new file mode 100644
index 0000000..43bb386
--- /dev/null
+++ b/recipes-bsp/mwifiexap/mwifiexap_1.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "MWiFiEx AP mode"
+DESCRIPTION = "Currently wifi chip fw \
+doesn't support mode changes, this creates\
+multiple interfaces on boot"
+
+inherit systemd
+
+LICENSE = "CLOSED"
+
+SRC_URI = "file://mwifiex.conf \
+ "
+
+do_install () {
+ install -d ${D}/etc/modprobe.d/
+ install -m 0755 ${WORKDIR}/mwifiex.conf ${D}/etc/modprobe.d/mwifiex.conf
+}
+