summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/device-tree-overlays-mainline_git.bb
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2021-02-15 11:06:36 +0100
committerMing Liu <ming.liu@toradex.com>2021-03-04 11:52:13 +0100
commit3f3703403ce8451c997faee1eb1f7665bff24437 (patch)
treea5b6e383ae53e80375c67e4e505831ef595f3e95 /recipes-kernel/linux/device-tree-overlays-mainline_git.bb
parentc8651feae915eeac23510565dde0f64557696de7 (diff)
toradex-devicetree.bbclass: introduce bbclass file
The major reason for doing this is because we are currently deploying all dtbo files to ${DEPLOY_DIR_IMAGE}/devicetree, but not machine specific ones, and they will be unnecessarily bundled into fitimage when kernel-fitimage.bbclass is being inherited. To fix that, we introduce a extra task do_collect_overlays to collect machine specific overlays to ${DT_FILES_PATH} before do_compile, where dtb compilation is being compiled in. In this way, only machine specific overlays would be compiled and deployed. Now we can drop device-tree-overlay-filter recipe with this change. Related-to: TOR-1700 Signed-off-by: Ming Liu <ming.liu@toradex.com>
Diffstat (limited to 'recipes-kernel/linux/device-tree-overlays-mainline_git.bb')
-rw-r--r--recipes-kernel/linux/device-tree-overlays-mainline_git.bb12
1 files changed, 1 insertions, 11 deletions
diff --git a/recipes-kernel/linux/device-tree-overlays-mainline_git.bb b/recipes-kernel/linux/device-tree-overlays-mainline_git.bb
index bf62db2..cc34553 100644
--- a/recipes-kernel/linux/device-tree-overlays-mainline_git.bb
+++ b/recipes-kernel/linux/device-tree-overlays-mainline_git.bb
@@ -1,17 +1,7 @@
-SUMMARY = "Toradex BSP device tree overlays"
-DESCRIPTION = "Toradex BSP device tree overlays from within layer."
-
-SRC_URI = "git://git.toradex.com/device-tree-overlays.git;branch=${SRCBRANCH};protocol=https"
+inherit toradex-devicetree
SRCBRANCH = "toradex_5.4.y"
-
SRCREV = "b4bc095e8b8c2613c8c9a10c1895b544652f8cf4"
SRCREV_use-head-next = "${AUTOREV}"
-PV = "${SRCBRANCH}+git${SRCPV}"
-
-inherit devicetree
-
-S = "${WORKDIR}/git/overlays"
-
COMPATIBLE_MACHINE = ".*(mx[678]|tegra124).*"