summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOleksandr Suvorov <oleksandr.suvorov@toradex.com>2020-05-23 20:36:25 +0300
committerOleksandr Suvorov <oleksandr.suvorov@toradex.com>2020-05-25 11:21:01 +0300
commit8ad5eecdcb37275ca9f46ada16a7d9257efcfbc7 (patch)
tree73626daed1d21f577c867fbd74a72973240797bd /recipes-kernel
parentfeec808563c1ebcb0904982c8b385367e12268da (diff)
linux-toradex: prepare shared_dir better
backports-5.4 requires Makefile in kernel shared_dir to be built successfully. Expand do_shared_workdir() accordingly. Related-to: ELB-2724 Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-toradex_%.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-toradex_%.bbappend b/recipes-kernel/linux/linux-toradex_%.bbappend
new file mode 100644
index 0000000..04a2451
--- /dev/null
+++ b/recipes-kernel/linux/linux-toradex_%.bbappend
@@ -0,0 +1,15 @@
+do_shared_workdir_append () {
+ if [ -f include/config/auto.conf ]; then
+ mkdir -p $kerneldir/include/config/
+ cp -f include/config/auto.conf $kerneldir/include/config/
+ fi
+
+ ln -sf ${STAGING_KERNEL_DIR} ${kerneldir}/source
+
+ if [ ! -f $kerneldir/Makefile ]; then
+ VERSION=$(grep "^VERSION =" Makefile | sed s/.*=\ *//)
+ PATCHLEVEL=$(grep "^PATCHLEVEL =" Makefile | sed s/.*=\ *//)
+ bash ${S}/scripts/mkmakefile $(pwd) $kerneldir $VERSION $PATCHLEVEL
+ fi
+}
+