summaryrefslogtreecommitdiff
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2020-05-05 09:46:05 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2020-05-15 02:32:48 +0200
commitce34d815ef6be7cd30c173e8305ec9cdc39f06ff (patch)
tree41d40d7e01e199992eb8930b48f5d1a077f29b1c /recipes-kernel
parentdc05d0b009a764f12acfac614d85c45f74e88297 (diff)
backports: replace hardcodeded path with oe prefix
Backported from 7ed9958daea9 commit. Related-to: TOR-992 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/backports/backports_5.4.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/recipes-kernel/backports/backports_5.4.bb b/recipes-kernel/backports/backports_5.4.bb
index 4d74c62..efa8436 100644
--- a/recipes-kernel/backports/backports_5.4.bb
+++ b/recipes-kernel/backports/backports_5.4.bb
@@ -22,7 +22,7 @@ SRC_URI = " \
git://git.toradex.com/backports-toradex.git;protocol=git;branch=toradex-${PV} \
file://config \
file://${DEPMOD_CONF} \
- "
+"
# Depend on virtual/kernel to ensure that the kernel is built before we try to
# build the backports
@@ -34,7 +34,7 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = " \
KLIB_BUILD=${KBUILD_OUTPUT} \
KLIB=${B} \
- "
+"
do_configure() {
# Somehow lex does not automatically get linked to flex!
@@ -53,13 +53,13 @@ do_compile() {
}
do_install() {
- install -d ${D}/etc/depmod.d/
- install -m 0644 ${WORKDIR}/${DEPMOD_CONF} ${D}/etc/depmod.d/${DEPMOD_CONF}
+ install -d ${D}${sysconfdir}/depmod.d/
+ install -m 0644 ${WORKDIR}/${DEPMOD_CONF} ${D}${sysconfdir}/depmod.d/${DEPMOD_CONF}
- install -d ${D}/lib/modules/${KERNEL_VERSION}/backports
+ install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/backports
for ko in $(find ${S} -type f -name "*.ko")
do
- install -m 0644 $ko ${D}/lib/modules/${KERNEL_VERSION}/backports/
+ install -m 0644 $ko ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/backports/
done
}
@@ -80,6 +80,6 @@ pkg_postrm_${PN} () {
}
FILES_${PN} = " \
- /etc/depmod.d/${DEPMOD_CONF} \
- /lib/modules/${KERNEL_VERSION}/backports/ \
- "
+ ${sysconfdir}/depmod.d/${DEPMOD_CONF} \
+ ${nonarch_base_libdir}/modules/${KERNEL_VERSION}/backports/ \
+"