summaryrefslogtreecommitdiff
path: root/conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf')
-rw-r--r--conf/layer.conf9
1 files changed, 5 insertions, 4 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
index 2c63546..c00306b 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -1,9 +1,8 @@
-# We have a conf and classes directory, add to BBPATH
+# We have a conf and classes directory, append to BBPATH
BBPATH .= ":${LAYERDIR}"
-# We have a recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "toradex-bsp-common-layer"
BBFILE_PATTERN_toradex-bsp-common-layer = "^${LAYERDIR}/"
@@ -16,3 +15,5 @@ BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
# Add layer-specific bb files too
BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
for layer in BBFILE_COLLECTIONS.split())}"
+
+LAYERDEPENDS_toradex-bsp-common-layer = "core"