summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-05-16 19:51:22 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-05-22 10:04:19 +0200
commit2e99a4017a3bc92402ecac9afc3159d29ba637aa (patch)
tree39358dd0df13410e2d6606011a15058cd38639d6
parent0d02e0bd8b423c642cec0e997ceadd89ffb9a0de (diff)
images: cleanup
packagegroup-base-extended is installed by inheriting core-image. packagegroup-basic installs dropbear, openssh-sftp, openssh-sftp-server dropbear can act as an scp client, drop openssh-scp Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-images/images/console-tdx-image.bb5
-rw-r--r--recipes-images/images/lxde-image.bb5
-rw-r--r--recipes-images/images/lxqt-image.bb5
-rw-r--r--recipes-images/images/qt5-x11-image.bb5
-rw-r--r--recipes-images/images/tdx-extra.inc2
5 files changed, 8 insertions, 14 deletions
diff --git a/recipes-images/images/console-tdx-image.bb b/recipes-images/images/console-tdx-image.bb
index fa9cc73..90c35ca 100644
--- a/recipes-images/images/console-tdx-image.bb
+++ b/recipes-images/images/console-tdx-image.bb
@@ -4,6 +4,8 @@ DESCRIPTION = "Image without graphical interface"
LICENSE = "MIT"
+inherit core-image
+
#start of the resulting deployable tarball name
export IMAGE_BASENAME = "Console-Image"
MACHINE_NAME ?= "${MACHINE}"
@@ -32,7 +34,6 @@ IMAGE_INSTALL += " \
${CONMANPKGS} \
${ROOTFS_PKGMANAGE_PKGS} \
timestamp-service \
- packagegroup-base-extended \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \
'weston weston-examples', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', \
@@ -46,5 +47,3 @@ IMAGE_DEV_MANAGER = "udev"
IMAGE_INIT_MANAGER = "systemd"
IMAGE_INITSCRIPTS = " "
IMAGE_LOGIN_MANAGER = "busybox shadow"
-
-inherit core-image
diff --git a/recipes-images/images/lxde-image.bb b/recipes-images/images/lxde-image.bb
index 3827566..23ff7fd 100644
--- a/recipes-images/images/lxde-image.bb
+++ b/recipes-images/images/lxde-image.bb
@@ -4,6 +4,8 @@ DESCRIPTION = "Image with the LXDE desktop environment"
LICENSE = "MIT"
+inherit core-image
+
#start of the resulting deployable tarball name
export IMAGE_BASENAME = "LXDE-Image"
MACHINE_NAME ?= "${MACHINE}"
@@ -192,7 +194,6 @@ IMAGE_INSTALL += " \
${CONMANPKGS} \
${ROOTFS_PKGMANAGE_PKGS} \
timestamp-service \
- packagegroup-base-extended \
xserver-common \
xauth \
xhost \
@@ -229,5 +230,3 @@ IMAGE_DEV_MANAGER = "udev"
IMAGE_INIT_MANAGER = "systemd"
IMAGE_INITSCRIPTS = " "
IMAGE_LOGIN_MANAGER = "busybox shadow"
-
-inherit core-image
diff --git a/recipes-images/images/lxqt-image.bb b/recipes-images/images/lxqt-image.bb
index e2f2fc2..0d67ade 100644
--- a/recipes-images/images/lxqt-image.bb
+++ b/recipes-images/images/lxqt-image.bb
@@ -4,6 +4,8 @@ DESCRIPTION = "Image with the LXQT desktop environment"
LICENSE = "MIT"
+inherit core-image
+
#start of the resulting deployable tarball name
export IMAGE_BASENAME = "LXQt-Image"
MACHINE_NAME ?= "${MACHINE}"
@@ -209,7 +211,6 @@ IMAGE_INSTALL += " \
${CONMANPKGS} \
${ROOTFS_PKGMANAGE_PKGS} \
timestamp-service \
- packagegroup-base-extended \
xserver-common \
xauth \
xhost \
@@ -253,5 +254,3 @@ IMAGE_DEV_MANAGER = "udev"
IMAGE_INIT_MANAGER = "systemd"
IMAGE_INITSCRIPTS = " "
IMAGE_LOGIN_MANAGER = "busybox shadow"
-
-inherit core-image
diff --git a/recipes-images/images/qt5-x11-image.bb b/recipes-images/images/qt5-x11-image.bb
index 8436515..55f6122 100644
--- a/recipes-images/images/qt5-x11-image.bb
+++ b/recipes-images/images/qt5-x11-image.bb
@@ -9,6 +9,8 @@ DESCRIPTION = "Image with the Qt5 Framework and the X11 server"
LICENSE = "MIT"
+inherit core-image
+
#start of the resulting deployable tarball name
export IMAGE_BASENAME = "Qt5-X11-Image"
MACHINE_NAME ?= "${MACHINE}"
@@ -172,7 +174,6 @@ IMAGE_INSTALL += " \
${CONMANPKGS} \
${ROOTFS_PKGMANAGE_PKGS} \
timestamp-service \
- packagegroup-base-extended \
xserver-common \
xserver-xorg-extension-dbe \
xserver-xorg-extension-extmod \
@@ -212,5 +213,3 @@ IMAGE_DEV_MANAGER = "udev"
IMAGE_INIT_MANAGER = "systemd"
IMAGE_INITSCRIPTS = " "
IMAGE_LOGIN_MANAGER = "busybox shadow"
-
-inherit core-image
diff --git a/recipes-images/images/tdx-extra.inc b/recipes-images/images/tdx-extra.inc
index 3975f56..dac346e 100644
--- a/recipes-images/images/tdx-extra.inc
+++ b/recipes-images/images/tdx-extra.inc
@@ -154,8 +154,6 @@ IMAGE_INSTALL += " \
curl \
can-utils iproute2 \
nfs-utils-client \
- openssh-scp \
- openssh-sftp \
\
bzip2 \
gdbserver \