summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2015-12-26 13:57:02 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-09-29 06:31:16 +0200
commit99197f671cfffca7c201115a70265575b34b94d4 (patch)
tree5c2dd7c62cf266e523f9e2d19de5b5cb3eb37020
parenta9b3111a10c87eb6c93b5bcbf2fefbecb1a53aa2 (diff)
recipes: stop using base_contains
The base_contains function is deprecated and we ought to use bb.utils.contains instead. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
-rw-r--r--recipes-devtools/python/python_2.7.9.bbappend4
-rw-r--r--recipes-lxde/lxdm/lxdm_git.bbappend2
-rw-r--r--recipes-qt/qt5/qtbase_%.bbappend2
-rw-r--r--recipes-sato/webkit/webkitgtk_2.8.5.bbappend2
4 files changed, 5 insertions, 5 deletions
diff --git a/recipes-devtools/python/python_2.7.9.bbappend b/recipes-devtools/python/python_2.7.9.bbappend
index ff0071f..64d3787 100644
--- a/recipes-devtools/python/python_2.7.9.bbappend
+++ b/recipes-devtools/python/python_2.7.9.bbappend
@@ -7,9 +7,9 @@ PACKAGECONFIG ?= ""
PACKAGECONFIG[tkinter] = ",,tk"
PACKAGECONFIG_remove_class-native = "tkinter"
PACKAGECONFIG_remove_class-nativesdk = "tkinter"
-RDEPENDS_${PN}-tkinter_append += "${@base_contains('PACKAGECONFIG', 'tkinter', 'tcl tk', '', d)}"
+RDEPENDS_${PN}-tkinter_append += "${@bb.utils.contains('PACKAGECONFIG', 'tkinter', 'tcl tk', '', d)}"
SRC_URI += " \
- ${@base_contains('PACKAGECONFIG', 'tkinter', '', 'file://dont_build_tkinter.patch', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'tkinter', '', 'file://dont_build_tkinter.patch', d)} \
"
python __anonymous() {
if not 'openembedded-layer' in d.getVar('BBFILE_COLLECTIONS'):
diff --git a/recipes-lxde/lxdm/lxdm_git.bbappend b/recipes-lxde/lxdm/lxdm_git.bbappend
index 7b868dd..4fc4051 100644
--- a/recipes-lxde/lxdm/lxdm_git.bbappend
+++ b/recipes-lxde/lxdm/lxdm_git.bbappend
@@ -3,5 +3,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/lxdm:"
SRC_URI += " \
file://logout-fixes.patch \
file://root-autologin.patch \
- ${@base_contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \
+ ${@bb.utils.contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \
"
diff --git a/recipes-qt/qt5/qtbase_%.bbappend b/recipes-qt/qt5/qtbase_%.bbappend
index 40d8286..bce4665 100644
--- a/recipes-qt/qt5/qtbase_%.bbappend
+++ b/recipes-qt/qt5/qtbase_%.bbappend
@@ -8,7 +8,7 @@ PACKAGECONFIG_EXAMPLES ?= "examples"
# | /build/krm/oe-core_V2.6/build/out-glibc/work/armv7at2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.1+gitAUTOINC+5afc431323-r0/git/src/widgets/styles/qgtkstyle.cpp:3636:74: error: 'QAccessible' has not been declared
# | } else if (QStyleHelper::isInstanceOf(groupBox->styleObject, QAccessible::Grouping)) {
-QT_CONFIG_FLAGS_append = "${@base_contains('DISTRO_FEATURES', 'x11', ' -accessibility ', '', d)}"
+QT_CONFIG_FLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -accessibility ', '', d)}"
#qtbase must be configured with icu for qtwebkit
PACKAGECONFIG_append_tegra = " \
diff --git a/recipes-sato/webkit/webkitgtk_2.8.5.bbappend b/recipes-sato/webkit/webkitgtk_2.8.5.bbappend
index 23fcaec..4933e4e 100644
--- a/recipes-sato/webkit/webkitgtk_2.8.5.bbappend
+++ b/recipes-sato/webkit/webkitgtk_2.8.5.bbappend
@@ -5,7 +5,7 @@ do_install_append() {
install -m 0644 -D ${WORKDIR}/minibrowser.desktop ${D}${datadir}/applications/minibrowser.desktop
}
-PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)}"
+PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)}"
ARM_INSTRUCTION_SET_vf = "thumb"