summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-01-07 19:37:11 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 13:46:01 +0100
commit2251d4fd97cc037a4ebf2d168da369bd052b8e82 (patch)
treed8279a6814aab1f3daeec667d1ffacf89e168f14
parentc1c098080b8ab5b3c612d4a86c03bdade69fe3e8 (diff)
distro: move from angstrom to a poky based distro
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--README42
-rw-r--r--buildconf/bblayers.conf4
-rw-r--r--buildconf/export6
-rw-r--r--buildconf/local.conf6
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-angstrom/angstrom/angstrom-feed-configs.bbappend9
-rw-r--r--recipes-images/images/console-tdx-image.bb4
-rw-r--r--recipes-images/images/lxde-image.bb (renamed from recipes-images/images/angstrom-lxde-image.bb)4
-rw-r--r--recipes-images/images/lxqt-image.bb (renamed from recipes-images/images/angstrom-lxqt-image.bb)4
-rw-r--r--recipes-images/images/qt-x11-image.bb (renamed from recipes-images/images/angstrom-qt-x11-image.bb)4
-rw-r--r--recipes-images/images/qt4e-demo-image.bb2
-rw-r--r--recipes-images/images/qt5-x11-image.bb (renamed from recipes-images/images/angstrom-qt5-x11-image.bb)4
12 files changed, 43 insertions, 48 deletions
diff --git a/README b/README
index 40749db..373a050 100644
--- a/README
+++ b/README
@@ -12,14 +12,20 @@ Dependencies
============
This layer depends on the relevant BSP layers for your machine and:
+(please check http://git.toradex.com/cgit/toradex-bsp-platform.git/ to get
+the specific layer versions we used when building our binary demo images)
URI: git://git.openembedded.org/bitbake
- branch: 1.36
+ branch: 1.40
revision: HEAD
URI: git://git.openembedded.org/openembedded-core
layer: meta
- branch: rocko
+ branch: thud
+
+ URI: git://git.openembedded.org/meta-yocto
+ layer: meta-poky
+ branch: thud
revision: HEAD
URI: git://git.openembedded.org/meta-openembedded
@@ -28,35 +34,35 @@ This layer depends on the relevant BSP layers for your machine and:
meta-multimedia
meta-networking
meta-oe
- branch: rocko
- revision: HEAD
-
- URI: https://github.com/angstrom-distribution/meta-angstrom.git
- branch: angstrom-v2017.12-rocko
+ branch: thud
revision: HEAD
URI: https://github.com/OSSystems/meta-browser.git
branch: master
- revision: cf35eca0de52d5a34dabe2068e68348367db8e55
+ revision: HEAD
URI: git://git.yoctoproject.org/meta-freescale
- branch: rocko
+ branch: thud
revision: HEAD
URI: https://github.com/freescale/meta-freescale-distro.git
- branch: rocko
+ branch: thud
revision: HEAD
URI: git://git.toradex.com/meta-lxde.git
- branch: rocko
+ branch: thud
revision: HEAD
URI: git://git.yoctoproject.org/meta-qt4
- branch: rocko
+ branch: thud
revision: HEAD
URI: https://github.com/meta-qt5/meta-qt5
- branch: rocko
+ branch: thud
+ revision: HEAD
+
+ URI: https://github.com/schnitzeltony/meta-qt5-extra.git
+ branch: thud
revision: HEAD
Patches
@@ -76,7 +82,7 @@ I. Building the meta-toradex-demos Layer
========================================
For information on how to use the modules with Linux and instructions on how
-to build the angstrom based demo images please visit:
+to build the demo images please visit:
http://developer.toradex.com/software/linux
http://developer.toradex.com/knowledge-base/board-support-package/openembedded-(core)
@@ -84,14 +90,14 @@ For support, visit the Toradex Developer Community:
https://www.toradex.com/community
Images built with this layer can be found here:
-http://developer.toradex.com/files/toradex-dev/uploads/media/Colibri/Linux/Images/
+https://developer.toradex.com/software/linux/linux-software#Binary_Images
II. Deploying Built Images
==========================
-http://developer.toradex.com/knowledge-base/flashing-linux-on-imx6-modules
-http://developer.toradex.com/knowledge-base/flashing-embedded-linux-to-imx7-modules
-http://developer.toradex.com/knowledge-base/flashing-linux-on-vybrid-modules
+Links to the image type and module specific flashing instructions can be found
+here:
+https://developer.toradex.com/software/linux/linux-software#Binary_Images
License
=======
diff --git a/buildconf/bblayers.conf b/buildconf/bblayers.conf
index 5f41360..1242a98 100644
--- a/buildconf/bblayers.conf
+++ b/buildconf/bblayers.conf
@@ -6,9 +6,6 @@ BBPATH = "${TOPDIR}"
BBFILES ?= ""
BBLAYERS ?= " \
- ${TOPDIR}/../layers/meta-angstrom \
- \
- \
${TOPDIR}/../layers/meta-toradex-nxp \
${TOPDIR}/../layers/meta-freescale \
${TOPDIR}/../layers/meta-freescale-3rdparty \
@@ -37,4 +34,5 @@ BBLAYERS ?= " \
\
\
${TOPDIR}/../layers/openembedded-core/meta \
+ ${TOPDIR}/../layers/meta-yocto/meta-poky \
"
diff --git a/buildconf/export b/buildconf/export
index ca13ba1..aea4b28 100644
--- a/buildconf/export
+++ b/buildconf/export
@@ -2,7 +2,7 @@
ECHO=`which echo`
BUILDDIR="../../build"
FIRST_TIME=0
-cd layers/openembedded-core/
+cd layers/openembedded-core
if [ ! -f ${BUILDDIR}/conf/local.conf ]; then
FIRST_TIME=1
fi
@@ -11,9 +11,9 @@ fi
echo ""
echo "Toradex targets are:"
-echo " angstrom-lxde-image"
echo " console-tdx-image"
-echo " angstrom-qt-x11-image"
+echo " other (unsupported) targets may be found in"
+echo " meta-toradex-demos/recipes-images/images/"
if [ $FIRST_TIME -eq 1 ]; then
mkdir -p conf
diff --git a/buildconf/local.conf b/buildconf/local.conf
index f38a8fe..af875a4 100644
--- a/buildconf/local.conf
+++ b/buildconf/local.conf
@@ -256,11 +256,11 @@ INHERIT += "rm_work"
# Add Toradex source mirror
INHERIT += "toradex-mirrors"
-# Use this distro (filename from meta-angstrom/conf/distro/xx.conf)
-DISTRO = "angstrom"
+# Use this distro
+DISTRO = "poky"
# What image type(s) are to be built?
-IMAGE_FSTYPES += "tar.bz2"
+IMAGE_FSTYPES_append = " tar.bz2"
# Don't generate the mirror tarball for SCM repos, the snapshot is enough
# BB_GENERATE_MIRROR_TARBALLS = "0"
diff --git a/conf/layer.conf b/conf/layer.conf
index af70f69..ed870da 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -18,8 +18,8 @@ BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
LAYERDEPENDS_toradex-demos = " \
core \
+ yocto \
openembedded-layer gnome-layer multimedia-layer networking-layer \
- angstrom-layer \
browser-layer \
freescale-layer \
fsl-demos \
diff --git a/recipes-angstrom/angstrom/angstrom-feed-configs.bbappend b/recipes-angstrom/angstrom/angstrom-feed-configs.bbappend
deleted file mode 100644
index 192a6ed..0000000
--- a/recipes-angstrom/angstrom/angstrom-feed-configs.bbappend
+++ /dev/null
@@ -1,9 +0,0 @@
-ANGSTROM_URI = "http://feeds.toradex.com/angstrom"
-
-do_compile_append() {
- #no debug feed available so empty the feed configs
- echo "" > ${S}/${sysconfdir}/opkg/debug-feed.conf
-
- #tdx: no machine feed available so empty the feed configs
- echo "" > ${S}/${sysconfdir}/opkg/${MACHINE_ARCH}-feed.conf
-}
diff --git a/recipes-images/images/console-tdx-image.bb b/recipes-images/images/console-tdx-image.bb
index a9734ab..9da53a2 100644
--- a/recipes-images/images/console-tdx-image.bb
+++ b/recipes-images/images/console-tdx-image.bb
@@ -1,6 +1,6 @@
SUMMARY = "Toradex Embedded Linux Console Demo"
SUMMARY_append_apalis-tk1-mainline = " (Mainline)"
-DESCRIPTION = "Angstrom-based image without graphical interface"
+DESCRIPTION = "Image without graphical interface"
LICENSE = "MIT"
@@ -40,7 +40,7 @@ CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-p
IMAGE_INSTALL_append_tegra124 = " ${XSERVER} xterm xclock"
IMAGE_INSTALL += " \
- angstrom-packagegroup-boot \
+ packagegroup-boot \
packagegroup-basic \
udev-extra-rules \
${CONMANPKGS} \
diff --git a/recipes-images/images/angstrom-lxde-image.bb b/recipes-images/images/lxde-image.bb
index 5bbd537..5118749 100644
--- a/recipes-images/images/angstrom-lxde-image.bb
+++ b/recipes-images/images/lxde-image.bb
@@ -1,6 +1,6 @@
SUMMARY = "Toradex Embedded Linux Demo with LXDE"
SUMMARY_append_apalis-tk1-mainline = " (Mainline)"
-DESCRIPTION = "Angstrom-based image with the LXDE desktop environment"
+DESCRIPTION = "Image with the LXDE desktop environment"
LICENSE = "MIT"
@@ -203,7 +203,7 @@ IMAGE_INSTALL += " \
makedevs \
xcursor-transparent-theme \
zeroconf \
- angstrom-packagegroup-boot \
+ packagegroup-boot \
packagegroup-basic \
udev-extra-rules \
${CONMANPKGS} \
diff --git a/recipes-images/images/angstrom-lxqt-image.bb b/recipes-images/images/lxqt-image.bb
index 76dba2e..97cac18 100644
--- a/recipes-images/images/angstrom-lxqt-image.bb
+++ b/recipes-images/images/lxqt-image.bb
@@ -1,6 +1,6 @@
SUMMARY = "Toradex Embedded Linux Demo with LXQT"
SUMMARY_append_apalis-tk1-mainline = " (Mainline)"
-DESCRIPTION = "Angstrom-based image with the LXQT desktop environment"
+DESCRIPTION = "Image with the LXQT desktop environment"
LICENSE = "MIT"
@@ -217,7 +217,7 @@ IMAGE_INSTALL += " \
makedevs \
xcursor-transparent-theme \
zeroconf \
- angstrom-packagegroup-boot \
+ packagegroup-boot \
packagegroup-basic \
udev-extra-rules \
${CONMANPKGS} \
diff --git a/recipes-images/images/angstrom-qt-x11-image.bb b/recipes-images/images/qt-x11-image.bb
index db1d643..fcc3b5e 100644
--- a/recipes-images/images/angstrom-qt-x11-image.bb
+++ b/recipes-images/images/qt-x11-image.bb
@@ -1,6 +1,6 @@
SUMMARY = "Toradex Embedded Linux Qt4 Demo With X11"
SUMMARY_append_apalis-tk1-mainline = " (Mainline)"
-DESCRIPTION = "Angstrom-based image with the Qt4 Framework and the X11 server"
+DESCRIPTION = "Image with the Qt4 Framework and the X11 server"
LICENSE = "MIT"
@@ -199,7 +199,7 @@ IMAGE_INSTALL += " \
mime-support \
xcursor-transparent-theme \
zeroconf \
- angstrom-packagegroup-boot \
+ packagegroup-boot \
packagegroup-basic \
udev-extra-rules \
${CONMANPKGS} \
diff --git a/recipes-images/images/qt4e-demo-image.bb b/recipes-images/images/qt4e-demo-image.bb
index 7a2270f..2c757c2 100644
--- a/recipes-images/images/qt4e-demo-image.bb
+++ b/recipes-images/images/qt4e-demo-image.bb
@@ -37,7 +37,7 @@ IMAGE_INSTALL += " \
mime-support \
zeroconf \
fbset \
- angstrom-packagegroup-boot \
+ packagegroup-boot \
packagegroup-basic \
udev-extra-rules \
${CONMANPKGS} \
diff --git a/recipes-images/images/angstrom-qt5-x11-image.bb b/recipes-images/images/qt5-x11-image.bb
index a8e99f1..d1b1cde 100644
--- a/recipes-images/images/angstrom-qt5-x11-image.bb
+++ b/recipes-images/images/qt5-x11-image.bb
@@ -1,6 +1,6 @@
SUMMARY = "Toradex Embedded Linux Qt5 Demo With X11"
SUMMARY_append_apalis-tk1-mainline = " (Mainline)"
-DESCRIPTION = "Angstrom-based image with the Qt5 Framework and the X11 server"
+DESCRIPTION = "Image with the Qt5 Framework and the X11 server"
# after the boot systemd starts X and then a qt5 application, check
# recipes-graphics/x-window-simple-app/x-window-simple-app and
@@ -178,7 +178,7 @@ IMAGE_INSTALL += " \
mime-support \
xcursor-transparent-theme \
zeroconf \
- angstrom-packagegroup-boot \
+ packagegroup-boot \
packagegroup-basic \
udev-extra-rules \
${CONMANPKGS} \