summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMing Liu <ming.liu@toradex.com>2022-02-02 16:59:30 +0100
committerFrancesco Dolcini <francesco.dolcini@toradex.com>2022-02-17 08:53:01 +0000
commit097df183d8e70cfcf4267425c195a6dcfcdbc9ed (patch)
tree6c8b3a62e00fedb76fbeb23c0c377ee47a4510b3
parentfd7a7b83175368f809b237979e3f20304a5571de (diff)
connman: disable background scan
Disable BackgroundScan in main.conf. Related-to: ELB-4148 Signed-off-by: Ming Liu <ming.liu@toradex.com>
-rw-r--r--recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch41
-rw-r--r--recipes-connectivity/connman/connman/0001-connman-clock-ntp-client-should-not-update-time-time.patch (renamed from recipes-connectivity/connman/connman/0003-connman-clock-ntp-client-should-not-update-time-time.patch)0
-rw-r--r--recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch28
-rw-r--r--recipes-connectivity/connman/connman_%.bbappend4
4 files changed, 43 insertions, 30 deletions
diff --git a/recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch b/recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch
new file mode 100644
index 0000000..91949a2
--- /dev/null
+++ b/recipes-connectivity/connman/connman/0001-Adjust-main-configuration.patch
@@ -0,0 +1,41 @@
+From 0d23846576b53b6a2a8391a29d44e82bf3aed588 Mon Sep 17 00:00:00 2001
+From: Ming Liu <ming.liu@toradex.com>
+Date: Tue, 28 Dec 2021 13:50:13 +0100
+Subject: [PATCH] Adjust main configuration
+
+- Blacklist rndis nic's, we want them handled by systemd's networkd.
+- Disable background scan, to avoid significant increase in bandwidth.
+
+Upstream-Status: Inappropriate [Toradex specific]
+
+Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
+Signed-off-by: Ming Liu <ming.liu@toradex.com>
+---
+ src/main.conf | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/main.conf b/src/main.conf
+index 14965e1..24a17bf 100644
+--- a/src/main.conf
++++ b/src/main.conf
+@@ -23,7 +23,7 @@
+ # When BackgroundScanning is false, ConnMan will not perform any scan
+ # regardless of wifi is connected or not, unless it is requested by
+ # the user through a D-Bus call.
+-# BackgroundScanning = true
++BackgroundScanning = false
+
+ # Assume that service gateways also function as timeservers.
+ # UseGatewaysAsTimeservers = false
+@@ -67,7 +67,7 @@
+ # not be handled by ConnMan, if their first characters
+ # match any of the list entries. Default value is
+ # vmnet,vboxnet,virbr,ifb,ve-,vb-.
+-# NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-
++NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-,usb,rndis
+
+ # Allow ConnMan to change the system hostname. This can
+ # happen for example if we receive DHCP hostname option.
+--
+2.25.1
+
diff --git a/recipes-connectivity/connman/connman/0003-connman-clock-ntp-client-should-not-update-time-time.patch b/recipes-connectivity/connman/connman/0001-connman-clock-ntp-client-should-not-update-time-time.patch
index c570812..c570812 100644
--- a/recipes-connectivity/connman/connman/0003-connman-clock-ntp-client-should-not-update-time-time.patch
+++ b/recipes-connectivity/connman/connman/0001-connman-clock-ntp-client-should-not-update-time-time.patch
diff --git a/recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch b/recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch
deleted file mode 100644
index dd6bafa..0000000
--- a/recipes-connectivity/connman/connman/0002-main.conf-blacklist-rndis-nic-s.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 38a7afa59f0edc1e4c6a49e778e6456f6cd30446 Mon Sep 17 00:00:00 2001
-From: Max Krummenacher <max.krummenacher@toradex.com>
-Date: Fri, 30 Dec 2016 13:41:47 +0100
-Subject: [PATCH 2/2] main.conf: blacklist rndis nic's
-
-We want them handled by systemd's networkd.
-
-Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
----
- src/main.conf | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/main.conf b/src/main.conf
-index 14965e1..d7b2951 100644
---- a/src/main.conf
-+++ b/src/main.conf
-@@ -67,7 +67,7 @@
- # not be handled by ConnMan, if their first characters
- # match any of the list entries. Default value is
- # vmnet,vboxnet,virbr,ifb,ve-,vb-.
--# NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-
-+NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,ve-,vb-,usb,rndis
-
- # Allow ConnMan to change the system hostname. This can
- # happen for example if we receive DHCP hostname option.
---
-2.13.6
-
diff --git a/recipes-connectivity/connman/connman_%.bbappend b/recipes-connectivity/connman/connman_%.bbappend
index af4b20f..3400da3 100644
--- a/recipes-connectivity/connman/connman_%.bbappend
+++ b/recipes-connectivity/connman/connman_%.bbappend
@@ -1,8 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/connman:"
SRC_URI_append = " \
- file://0002-main.conf-blacklist-rndis-nic-s.patch \
- file://0003-connman-clock-ntp-client-should-not-update-time-time.patch \
+ file://0001-Adjust-main-configuration.patch \
+ file://0001-connman-clock-ntp-client-should-not-update-time-time.patch \
"
do_install_append() {