summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Schenker <philippe.schenker@toradex.com>2022-02-22 17:49:34 +0100
committerPhilippe Schenker <philippe.schenker@toradex.com>2022-02-22 17:49:34 +0100
commit422bcc1f363db546dd333db462adcddacda8a130 (patch)
treeeb6f78d73e7880927e9870e4d38fb0cbe96f190b
parent77604d441e446858ced8a6a84039f708853cd361 (diff)
recipes benchmark: fio: add recipe for version 3.29
It turned out that the version 3.17 is buggy and caused high RAM usage which invoked OOM killer on our low-end <= 512M modules. Related-to: ELB-4382 Signed-off-by: Philippe Schenker <philippe.schenker@toradex.com>
-rw-r--r--recipes-benchmark/fio/fio_3.29.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-benchmark/fio/fio_3.29.bb b/recipes-benchmark/fio/fio_3.29.bb
new file mode 100644
index 0000000..40f2b2a
--- /dev/null
+++ b/recipes-benchmark/fio/fio_3.29.bb
@@ -0,0 +1,49 @@
+SUMMARY = "Filesystem and hardware benchmark and stress tool"
+DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
+stress/hardware verification. It has support for a number of I/O engines, \
+I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
+and much more. It can work on block devices as well as files. fio accepts \
+job descriptions in a simple-to-understand text format. Several example job \
+files are included. fio displays all sorts of I/O performance information."
+HOMEPAGE = "http://freecode.com/projects/fio"
+SECTION = "console/tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "libaio zlib coreutils-native"
+DEPENDS += "${@bb.utils.contains('MACHINE_FEATURES', 'pmem', 'pmdk', '', d)}"
+RDEPENDS_${PN} = "python3-core bash"
+
+PACKAGECONFIG_NUMA = "numa"
+# ARM does not currently support NUMA
+PACKAGECONFIG_NUMA_arm = ""
+PACKAGECONFIG_NUMA_armeb = ""
+
+PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
+PACKAGECONFIG[numa] = ",--disable-numa,numactl"
+
+SRCREV = "9b46661c289d01dbfe5182189a7abea9ce2f9e04"
+SRC_URI = "git://git.kernel.dk/fio.git;branch=master \
+"
+
+S = "${WORKDIR}/git"
+
+# avoids build breaks when using no-static-libs.inc
+DISABLE_STATIC = ""
+
+EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
+EXTRA_OECONF = "${@bb.utils.contains('MACHINE_FEATURES', 'x86', '--disable-optimizations', '', d)}"
+
+do_configure() {
+ ./configure ${EXTRA_OECONF}
+
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
+ install -d ${D}/${docdir}/${PN}
+ cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/
+
+}
+
+