summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Schenker <philippe.schenker@toradex.com>2020-12-02 10:00:12 +0100
committerPhilippe Schenker <philippe.schenker@toradex.com>2020-12-02 14:08:43 +0100
commitc79cc904871adae96d1c0d0743c5a2605cb25e20 (patch)
tree9562eb22c4a6ee1b3d0aef3f0e6c76eb0f7996e9
parentb962519c754bd918e99ff08e583f63ffb10757b0 (diff)
tdx-reference-multimedia-images: choose different qt demos
For low-end modules without GPU only show the QT analogclock. For TK1 also choose a different QT-demo. Related-to: ELB-3153 Signed-off-by: Philippe Schenker <philippe.schenker@toradex.com>
-rw-r--r--recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb9
-rw-r--r--recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb9
-rw-r--r--recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb9
-rw-r--r--recipes-images/images/tdx-reference-multimedia-image.bb14
4 files changed, 36 insertions, 5 deletions
diff --git a/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb
new file mode 100644
index 0000000..d11611e
--- /dev/null
+++ b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-analogclock_1.0.bb
@@ -0,0 +1,9 @@
+# set the following variable to your one and only application which should
+# be launched right after weston started
+
+INITIAL_APP_PKGS ?= "qtbase-examples qtwayland"
+INITIAL_PATH ?= ""
+APPLICATION_ENVIRONMENT ?= '\"QT_QPA_PLATFORM=wayland-egl\"'
+WAYLAND_APPLICATION ?= "/usr/share/examples/gui/analogclock/analogclock"
+
+require wayland-app-launch.inc
diff --git a/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb
new file mode 100644
index 0000000..b85fdf0
--- /dev/null
+++ b/recipes-graphics/wayland-app-launch/wayland-qtdemo-launch-qtsmarthome_1.0.bb
@@ -0,0 +1,9 @@
+# set the following variable to your one and only application which should
+# be launched right after weston started
+
+INITIAL_APP_PKGS ?= "qtsmarthome qtwayland"
+INITIAL_PATH ?= "/usr/share/qtsmarthome-1.0/"
+APPLICATION_ENVIRONMENT ?= '\"QT_QPA_PLATFORM=wayland-egl\"'
+WAYLAND_APPLICATION ?= "${INITIAL_PATH}/smarthome"
+
+require wayland-app-launch.inc
diff --git a/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb b/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb
new file mode 100644
index 0000000..c9bfd7a
--- /dev/null
+++ b/recipes-graphics/x-window-simple-app/x-window-analogclock_1.0.bb
@@ -0,0 +1,9 @@
+# set the following variable to your one and only application which should
+# be started
+
+INITIAL_APP_PKGS ?= "qtbase-examples"
+INITIAL_PATH ?= ""
+X_APPLICATION ?= "/usr/share/examples/gui/analogclock/analogclock"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/x-window-simple-app:"
+require recipes-graphics/x-window-simple-app/x-window-simple-app.inc
diff --git a/recipes-images/images/tdx-reference-multimedia-image.bb b/recipes-images/images/tdx-reference-multimedia-image.bb
index 4061872..c8d901b 100644
--- a/recipes-images/images/tdx-reference-multimedia-image.bb
+++ b/recipes-images/images/tdx-reference-multimedia-image.bb
@@ -17,12 +17,16 @@ IMAGE_FEATURES += " \
"
APP_LAUNCH_WAYLAND ?= "wayland-qtdemo-launch-cinematicexperience"
-APP_LAUNCH_X11 ?= "x-window-qtcinematicexperience"
+APP_LAUNCH_WAYLAND_colibri-imx6ull ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND_colibri-imx7 ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND_colibri-imx7-emmc ?= "wayland-qtdemo-launch-analogclock"
+APP_LAUNCH_WAYLAND_apalis-tk1 ?= "wayland-qtdemo-launch-qtsmarthome"
-APP_LAUNCH_X11_colibri-imx6ull ?= "x-window-qtsmarthome"
-APP_LAUNCH_X11_colibri-imx6 ?= "x-window-qtsmarthome"
-APP_LAUNCH_X11_mx7 ?= "x-window-qtsmarthome"
-APP_LAUNCH_X11_apalis-tk1 ?= "x-window-xterm"
+APP_LAUNCH_X11 ?= "x-window-qtcinematicexperience"
+APP_LAUNCH_X11_colibri-imx6ull ?= "x-window-analogclock"
+APP_LAUNCH_X11_colibri-imx7 ?= "x-window-analogclock"
+APP_LAUNCH_X11_colibri-imx7-emmc ?= "x-window-analogclock"
+APP_LAUNCH_X11_apalis-tk1 ?= "x-window-qtsmarthome"
IMAGE_INSTALL += " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', \