summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-11-20 10:34:21 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2013-11-21 18:49:12 +0100
commit06cd73e90f9475fff48bbd238703720056e0b1c1 (patch)
tree8f4ce7e93c758aff96946c11bc44427a275c48d4
parent081160fb167608c6862ddb1fc1142091cfe56345 (diff)
lxde-common: choose wallpaper for colibri-vf at runtime
-rw-r--r--recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend42
1 files changed, 30 insertions, 12 deletions
diff --git a/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend b/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend
index a0dc781..3b956ce 100644
--- a/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend
+++ b/recipes-lxde/lxde-common/lxde-common_0.5.5.bbappend
@@ -1,25 +1,29 @@
-PRINC = "8"
+PRINC = "9"
WALLPAPER-MACHINE = "Wallpaper_Toradex.png"
WALLPAPER-MACHINE_colibri-t20 = "Wallpaper_ColibriT20.png"
WALLPAPER-MACHINE_colibri-t30 = "Wallpaper_ColibriT30.png"
WALLPAPER-MACHINE_apalis-t30 = "Wallpaper_ApalisT30.png"
-WALLPAPER-MACHINE_colibri-vf50 = "Wallpaper_ColibriVF50.png"
-WALLPAPER-MACHINE_apalis-vf61 = "Wallpaper_ColibriVF61.png"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
PACKAGE_ARCH = "${MACHINE_ARCH}"
SRC_URI += " \
- file://autostart.patch \
- file://consistent_defconfig_dirs.patch \
- file://Wallpaper_Toradex.png \
- file://${WALLPAPER-MACHINE} \
- file://wallpaper.patch \
- file://desktop.conf \
- file://defaults.list \
- file://hdmiaudio.sh \
- file://panel-buttons.patch \
+ file://autostart.patch \
+ file://consistent_defconfig_dirs.patch \
+ file://Wallpaper_Toradex.png \
+ file://${WALLPAPER-MACHINE} \
+ file://wallpaper.patch \
+ file://desktop.conf \
+ file://defaults.list \
+ file://hdmiaudio.sh \
+ file://panel-buttons.patch \
+"
+
+# for colibri-vf50, colibri-vf61 we decide on the target during postinst
+SRC_URI_append_vf += " \
+ file://Wallpaper_ColibriVF50.png \
+ file://Wallpaper_ColibriVF61.png \
"
do_install_append () {
@@ -33,3 +37,17 @@ do_install_append () {
install -m 0755 -d ${D}/${bindir}
install -m 0755 ${WORKDIR}/hdmiaudio.sh ${D}/${bindir}/
}
+
+
+pkg_postinst_${PN}_vf () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ IS_VF50=`grep -c VF50 /proc/cpuinfo`
+ if [ $IS_VF50 -gt 0 ]; then
+ ln -sf Wallpaper_ColibriVF50.png ${datadir}/lxde/wallpapers/toradex.png
+ else
+ ln -sf Wallpaper_ColibriVF61.png ${datadir}/lxde/wallpapers/toradex.png
+ fi
+}