summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-10-06 14:19:40 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2014-10-06 14:19:40 +0200
commit0a74ebe988e58cb13453422dc83ad845a50a815d (patch)
treec8e14424304e5a023f057fa48bc43efdf1ff0e01
parentd6ec4ab58925add53bb1a6b5a8d70cde76d9f88f (diff)
qt5: fix build failure with V2.3 images
-rw-r--r--recipes-qt/qt5/files/0017-qt5-workaround-gcc48-arm-build-failure.patch11
-rw-r--r--recipes-qt/qt5/qtbase_5.2.1.bbappend17
2 files changed, 24 insertions, 4 deletions
diff --git a/recipes-qt/qt5/files/0017-qt5-workaround-gcc48-arm-build-failure.patch b/recipes-qt/qt5/files/0017-qt5-workaround-gcc48-arm-build-failure.patch
new file mode 100644
index 0000000..33882a3
--- /dev/null
+++ b/recipes-qt/qt5/files/0017-qt5-workaround-gcc48-arm-build-failure.patch
@@ -0,0 +1,11 @@
+--- a/src/tools/qdoc/qdoc.pro.orig 2014-07-06 21:10:09.054048842 +0200
++++ b/src/tools/qdoc/qdoc.pro 2014-07-06 21:11:00.960577053 +0200
+@@ -74,6 +74,8 @@
+ tree.cpp \
+ yyindent.cpp
+
++QMAKE_CXXFLAGS_CXX11 =
++
+ ### QML/JS Parser ###
+
+ include(qmlparser/parser.pri)
diff --git a/recipes-qt/qt5/qtbase_5.2.1.bbappend b/recipes-qt/qt5/qtbase_5.2.1.bbappend
index 0682198..d06ff2d 100644
--- a/recipes-qt/qt5/qtbase_5.2.1.bbappend
+++ b/recipes-qt/qt5/qtbase_5.2.1.bbappend
@@ -1,9 +1,18 @@
-
-PACKAGECONFIG_GLES2 ?= "gles2"
+PACKAGECONFIG_GL_tegra = "gles2"
PACKAGECONFIG_EXAMPLES ?= "examples"
-PACKAGECONFIG += " \
- ${PACKAGECONFIG_GLES2} \
+PACKAGECONFIG_append_tegra += " \
${PACKAGECONFIG_EXAMPLES} \
"
+PACKAGECONFIG_append_vf += " \
+ ${PACKAGECONFIG_EXAMPLES} \
+"
+# Workaround from the Fedora ARM port preventing the following compiler error
+# happening with the Linaro 4.8. 2014.04 toolchain
+# qtbase-opensource-src-5.2.1/src/tools/qdoc/quoter.cpp:139:1: internal compiler error: in add_stores, at var-tracking.c:5918
+#
+# https://bugs.linaro.org/show_bug.cgi?id=534
+# http://pkgs.fedoraproject.org/cgit/mingw-qt5-qtbase.git/tree/qt5-workaround-gcc48-arm-build-failure.patch?h=f20
+FILESEXTRAPATHS_prepend := "${THISDIR}/files/:"
+SRC_URI += "file://0017-qt5-workaround-gcc48-arm-build-failure.patch"