summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2014-03-17 16:07:40 +0100
committerStefan Agner <stefan.agner@toradex.com>2014-03-17 16:07:40 +0100
commit5660af2dc5d33f0d09466f7c14e2338946bea454 (patch)
treec143d51540cfd07d3382be034e07ad2daf53567b
parent7e65910e92a56496e1bcb8f0fdecf35a5cd76c3c (diff)
vybrid: backport Cortex-M utilites from meta-fsl
- Add utility mqxboot to load firmware into IRAM and reset M4 - Add kernel module mcc needed by libmcc - Add multi-core communication library libmcc for message queue based communication with Cortex-M core
-rw-r--r--recipes-bsp/libmcc/libmcc_1.04.bb18
-rw-r--r--recipes-bsp/mqxboot/mqxboot_1.0.bb18
-rw-r--r--recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.04.bb16
3 files changed, 52 insertions, 0 deletions
diff --git a/recipes-bsp/libmcc/libmcc_1.04.bb b/recipes-bsp/libmcc/libmcc_1.04.bb
new file mode 100644
index 0000000..2c3ebd8
--- /dev/null
+++ b/recipes-bsp/libmcc/libmcc_1.04.bb
@@ -0,0 +1,18 @@
+# Copyright (C) 2013 Timesys Corporation
+SUMMARY = "MCC Userspace Library"
+DESCRIPTION = "Timesys Multicore communication Library"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c49712341497d0b5f2e40c30dff2af9d"
+
+RDEPENDS_${PN} = "kernel-module-mcc"
+
+inherit autotools
+
+SRC_URI = "http://repository.timesys.com/buildsources/l/libmcc/libmcc-${PV}/libmcc-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "e93ce76b4419f0902a848e1769bf22ea"
+SRC_URI[sha256sum] = "3de76c5b1a096021afebfc79ca4e85d05646beb3101edcecf73b82886e7a00c0"
+
+S = "${WORKDIR}/libmcc-${PV}"
+
+COMPATIBLE_MACHINE = "(vf60)"
diff --git a/recipes-bsp/mqxboot/mqxboot_1.0.bb b/recipes-bsp/mqxboot/mqxboot_1.0.bb
new file mode 100644
index 0000000..17f0233
--- /dev/null
+++ b/recipes-bsp/mqxboot/mqxboot_1.0.bb
@@ -0,0 +1,18 @@
+# Copyright (C) 2013 Timesys Corporation
+SUMMARY = "mqxboot"
+DESCRIPTION = "Timesys MQX Image loader - starts an MQX image on the M4"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c49712341497d0b5f2e40c30dff2af9d"
+
+RDEPENDS_${PN} = "kernel-module-mcc"
+
+inherit autotools
+
+SRC_URI = "http://repository.timesys.com/buildsources/m/mqxboot/mqxboot-${PV}/mqxboot-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "3de3c8b5f8cd6664870587d29c04c421"
+SRC_URI[sha256sum] = "c2f66ae962fe2529578d5c007e3f91a36085b714a0ea276f47bc3aea90e69699"
+
+S = "${WORKDIR}/mqxboot-${PV}"
+
+COMPATIBLE_MACHINE = "(vf60)"
diff --git a/recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.04.bb b/recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.04.bb
new file mode 100644
index 0000000..eed9339
--- /dev/null
+++ b/recipes-kernel/kernel-module-mcc/kernel-module-mcc_1.04.bb
@@ -0,0 +1,16 @@
+# Copyright (C) 2013 Timesys Corporation
+SUMMARY = "MCC KERNEL MODULE"
+DESCRIPTION = "Timesys Multicore communication kernel module"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c8959abcbbe4d6676c58eab9354019e6"
+
+inherit module
+
+SRC_URI = "http://repository.timesys.com/buildsources/m/mcc-kmod/mcc-kmod-${PV}/mcc-kmod-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "d72e8f6575605906be94ac2d26e6bc26"
+SRC_URI[sha256sum] = "f86a860e68cefdce70796572d97ddd4cc5e08d9f13117b431599add55bf1a651"
+
+S = "${WORKDIR}/mcc-kmod-${PV}"
+
+COMPATIBLE_MACHINE = "(vf60)"