summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2015-04-20 12:55:29 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2015-05-12 10:06:07 +0200
commitaad919e1271e8242af70034fe602608058655576 (patch)
tree47921a80b1ba2877d6f112815d4d14308ec6d2d7
parent78b96eef475c1001367d26141c70ec5e9b35be50 (diff)
Apalis/Colibri iMX6: kernel/U-Boot update to latest in -next
Also deploy an additional device tree supporting a Colibri iMX6 with Analog Camera Module.
-rw-r--r--conf/machine/apalis-imx6.conf2
-rw-r--r--conf/machine/colibri-imx6.conf4
-rw-r--r--recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb11
-rw-r--r--recipes-kernel/linux/linux-toradex-fsl_git.bb4
-rwxr-xr-xrecipes/images/files/library/imx6/update.sh2
5 files changed, 11 insertions, 12 deletions
diff --git a/conf/machine/apalis-imx6.conf b/conf/machine/apalis-imx6.conf
index 23d6528..c0f5fa5 100644
--- a/conf/machine/apalis-imx6.conf
+++ b/conf/machine/apalis-imx6.conf
@@ -20,7 +20,7 @@ PREFERRED_VERSION_xserver-xorg_mx6 = "99:1.14%"
# don't pull in systemd 216 backported into meta-angstrom
PREFERRED_VERSION_systemd = "211%"
-UBOOT_MACHINE = "apalis_imx6q1g_config"
+UBOOT_MACHINE = "apalis_imx6_defconfig"
SERIAL_CONSOLE = "115200 ttymxc0"
diff --git a/conf/machine/colibri-imx6.conf b/conf/machine/colibri-imx6.conf
index 25c1f36..b9ea652 100644
--- a/conf/machine/colibri-imx6.conf
+++ b/conf/machine/colibri-imx6.conf
@@ -12,7 +12,7 @@ SOC_FAMILY = "mx6:mx6dl"
PREFERRED_PROVIDER_u-boot = "u-boot-toradex-fsl"
PREFERRED_PROVIDER_virtual/bootloader = "u-boot-toradex-fsl"
PREFERRED_PROVIDER_virtual/kernel = "linux-toradex-fsl"
-KERNEL_DEVICETREE = "imx6dl-colibri-eval-v3.dtb"
+KERNEL_DEVICETREE = "imx6dl-colibri-eval-v3.dtb imx6dl-colibri-cam-eval-v3.dtb"
KERNEL_IMAGETYPE = "uImage"
PREFERRED_VERSION_xserver-xorg_mx6 = "99:1.14%"
@@ -20,7 +20,7 @@ PREFERRED_VERSION_xserver-xorg_mx6 = "99:1.14%"
# don't pull in systemd 216 backported into meta-angstrom
PREFERRED_VERSION_systemd = "211%"
-UBOOT_MACHINE = "colibri_imx6s256m_config"
+UBOOT_MACHINE = "colibri_imx6_defconfig"
SERIAL_CONSOLE = "115200 ttymxc0"
diff --git a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
index 9389a25..78bc4ff 100644
--- a/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
+++ b/recipes-bsp/u-boot/u-boot-toradex-fsl_git.bb
@@ -3,18 +3,17 @@ require recipes-bsp/u-boot/u-boot.inc
PROVIDES += "u-boot"
LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
-LIC_FILES_CHKSUM_colibri-vf = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
PV = "${PR}+gitr${SRCREV}"
PR = "r0"
S = "${WORKDIR}/git"
-SRCREV_colibri-vf = "93d011ae1319c297d3cf31d40a88b21699d89d7b"
+SRCREV_colibri-vf = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
SRCBRANCH_colibri-vf = "2015.04-toradex-next"
-SRCREV_mx6 = "0260e62f008aa292d87da7c1a9fbe1051a793518"
-SRCBRANCH_mx6 = "2014.04-toradex"
+SRCREV_mx6 = "a75dd7f7df968300e0213ff7f8cbc987df344d4c"
+SRCBRANCH_mx6 = "2015.04-toradex-next"
SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=${SRCBRANCH}"
#FILESPATHPKG =. "git:"
@@ -46,7 +45,7 @@ SPL_SYMLINK_apalis-imx6 = "u-boot-it-${MACHINE}.imx"
do_compile_append_apalis-imx6() {
# keep u-boot with standard timings
mv u-boot.imx u-boot-std.imx
- oe_runmake apalis_imx6q2g_config
+ oe_runmake apalis_imx6_defconfig
oe_runmake ${UBOOT_MAKE_TARGET}
mv u-boot.imx u-boot-it.imx
mv u-boot-std.imx u-boot.imx
diff --git a/recipes-kernel/linux/linux-toradex-fsl_git.bb b/recipes-kernel/linux/linux-toradex-fsl_git.bb
index 2932684..c7a9c1a 100644
--- a/recipes-kernel/linux/linux-toradex-fsl_git.bb
+++ b/recipes-kernel/linux/linux-toradex-fsl_git.bb
@@ -11,8 +11,8 @@ DEPENDS += "lzop-native "
LINUX_VERSION_mx6 = "3.10.17"
-SRCREV_mx6 = "23b22e549ed6ede5b44a948824463daafb6745c3"
-PR_mx6 = "V2.3b5"
+SRCREV_mx6 = "2927fd34b6cfc68e3db459cceebdaa9f6fea664d"
+PR_mx6 = "V2.4b1"
PV = "${LINUX_VERSION}+gitr${SRCREV}"
S = "${WORKDIR}/git"
diff --git a/recipes/images/files/library/imx6/update.sh b/recipes/images/files/library/imx6/update.sh
index d08ebca..98dea58 100755
--- a/recipes/images/files/library/imx6/update.sh
+++ b/recipes/images/files/library/imx6/update.sh
@@ -97,7 +97,7 @@ if [ "$CNT" -ge 1 ] ; then
IMAGEFILE=root.ext3
U_BOOT_BINARY=u-boot.imx
U_BOOT_BINARY_IT=u-boot.imx
- KERNEL_DEVICETREE="imx6dl-colibri-eval-v3.dtb"
+ KERNEL_DEVICETREE="imx6dl-colibri-eval-v3.dtb imx6dl-colibri-cam-eval-v3.dtb"
LOCPATH="imx_flash"
# eMMC size [in sectors of 512]
EMMC_SIZE=$(expr 1024 \* 3500 \* 2)