summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2014-03-17 16:09:01 +0100
committerStefan Agner <stefan.agner@toradex.com>2014-03-17 16:09:01 +0100
commitc85b7f7869d375efbfc34772e542a648abd1d3a8 (patch)
treec6647b5bbe786978d17216daf2143be9507be5ac
parent328beb17ada7e877e1f2675dddf70b7f56c5db7e (diff)
kernel/u-boot: update to latest git revision
-rw-r--r--recipes-bsp/u-boot/u-boot-colibri-vf.bb4
-rw-r--r--recipes-kernel/linux/linux-toradex-vf_git.bb27
2 files changed, 15 insertions, 16 deletions
diff --git a/recipes-bsp/u-boot/u-boot-colibri-vf.bb b/recipes-bsp/u-boot/u-boot-colibri-vf.bb
index 82039b7..afc211b 100644
--- a/recipes-bsp/u-boot/u-boot-colibri-vf.bb
+++ b/recipes-bsp/u-boot/u-boot-colibri-vf.bb
@@ -10,8 +10,8 @@ PV = "${PR}+gitr${SRCREV}"
PR = "r0"
S = "${WORKDIR}/git"
-SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-SRCREV_colibri-vf = "5017686683f7c2eb12bb966924c857622e9cdb94"
+SRC_URI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri_vf"
+SRCREV_colibri-vf = "f624e019a3f37ee4415a407afae0e026dd203714"
#FILESPATHPKG =. "git:"
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-kernel/linux/linux-toradex-vf_git.bb b/recipes-kernel/linux/linux-toradex-vf_git.bb
index ed03a0d..0894c20 100644
--- a/recipes-kernel/linux/linux-toradex-vf_git.bb
+++ b/recipes-kernel/linux/linux-toradex-vf_git.bb
@@ -3,8 +3,8 @@ require recipes-kernel/linux/linux.inc
LINUX_VERSION ?= "3.0.15"
-SRCREV_colibri-vf = "f9e4905e8ce8459bc4eb56ea8885170e36b849fb"
-PR_colibri-vf = "V2.1b2"
+SRCREV_colibri-vf = "aef4075a0bcc7860eafa17be0c6e6cfcecc68206"
+PR_colibri-vf = "V2.1b3"
PV = "${LINUX_VERSION}+gitr${SRCREV}"
S = "${WORKDIR}/git"
@@ -12,7 +12,6 @@ SRC_URI = "git://git.toradex.com/linux-toradex.git;protocol=git;branch=colibri_v
# a Patch
# SRC_URI += "file://a.patch "
-
COMPATIBLE_MACHINE_colibri-vf = "colibri-vf"
# Place changes to the defconfig here
@@ -36,18 +35,18 @@ do_configure_prepend () {
}
kernel_do_compile() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
- oe_runmake ${KERNEL_IMAGETYPE_FOR_MAKE} ${KERNEL_ALT_IMAGETYPE} LD="${KERNEL_LD}"
- if test "${KERNEL_IMAGETYPE_FOR_MAKE}.gz" = "${KERNEL_IMAGETYPE}"; then
- gzip -9c < "${KERNEL_IMAGETYPE_FOR_MAKE}" > "${KERNEL_OUTPUT}"
- fi
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
+ oe_runmake ${KERNEL_IMAGETYPE_FOR_MAKE} ${KERNEL_ALT_IMAGETYPE} LD="${KERNEL_LD}"
+ if test "${KERNEL_IMAGETYPE_FOR_MAKE}.gz" = "${KERNEL_IMAGETYPE}"; then
+ gzip -9c < "${KERNEL_IMAGETYPE_FOR_MAKE}" > "${KERNEL_OUTPUT}"
+ fi
}
do_compile_kernelmodules() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
- if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
- oe_runmake ${PARALLEL_MAKE} modules LD="${KERNEL_LD}"
- else
- bbnote "no modules to compile"
- fi
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS MACHINE
+ if (grep -q -i -e '^CONFIG_MODULES=y$' .config); then
+ oe_runmake ${PARALLEL_MAKE} modules LD="${KERNEL_LD}"
+ else
+ bbnote "no modules to compile"
+ fi
}