summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2014-03-29 12:28:59 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2014-04-01 10:11:35 +0200
commit516458900eda91785b13ba4f18a8c3e359ad2320 (patch)
tree2c6476247c1d8efb447b96b146947e872bbc44c4
parent8f59215ce41458a631173ae3e78196a80fa3d360 (diff)
u-boot: convert bbappend to a bb
-rw-r--r--recipes-bsp/u-boot/u-boot-fw-utils_2011.06.bbappend17
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.06.bbappend53
2 files changed, 0 insertions, 70 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fw-utils_2011.06.bbappend b/recipes-bsp/u-boot/u-boot-fw-utils_2011.06.bbappend
deleted file mode 100644
index 51482df..0000000
--- a/recipes-bsp/u-boot/u-boot-fw-utils_2011.06.bbappend
+++ /dev/null
@@ -1,17 +0,0 @@
-# Extends the core u-boot recipe
-# to take the u-boot sources including the colibri stuff from our git repository
-PR ="r7"
-COMPATIBLE_MACHINE_colibri-t20 = "colibri-t20"
-
-DEFAULT_PREFERENCE_colibri-t20 = "1"
-
-FILESPATHPKG =. "git:"
-S="${WORKDIR}/git"
-SRC_URI_COLIBRI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-SRCREV_COLIBRI = "d7fcf63504425a73f74f3d1d2f5ba68533280ff4"
-
-PV_colibri-t20 = "${PR}+gitr${SRCREV}"
-
-SRC_URI_colibri-t20 = "${SRC_URI_COLIBRI}"
-SRCREV_colibri-t20 = "${SRCREV_COLIBRI}"
-PV_colibri-t20 = "${PR}+gitr${SRCREV}"
diff --git a/recipes-bsp/u-boot/u-boot_2011.06.bbappend b/recipes-bsp/u-boot/u-boot_2011.06.bbappend
deleted file mode 100644
index ae9a82b..0000000
--- a/recipes-bsp/u-boot/u-boot_2011.06.bbappend
+++ /dev/null
@@ -1,53 +0,0 @@
-# Extends the core u-boot recipe
-# to take the u-boot sources including the colibri stuff from our git repository
-PR ="r7"
-DEPENDS += "dtc-native"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-COMPATIBLE_MACHINE_colibri-t20 = "colibri-t20"
-COMPATIBLE_MACHINE_colibri-t30 = "colibri-t30"
-COMPATIBLE_MACHINE_apalis-t30 = "apalis-t30"
-
-DEFAULT_PREFERENCE_colibri-t20 = "1"
-DEFAULT_PREFERENCE_colibri-t30 = "1"
-DEFAULT_PREFERENCE_apalis-t30 = "1"
-
-FILESPATHPKG =. "git:"
-S="${WORKDIR}/git"
-SRC_URI_COLIBRI = "git://git.toradex.com/u-boot-toradex.git;protocol=git;branch=colibri"
-#SRC_URI_COLIBRI += "file://u-boot-dont-build-standalone.patch"
-SRCREV_COLIBRI = "ccd521c4681a5850bbec1feec140eeaec33936b0"
-
-PV_colibri-t20 = "${PR}+gitr${SRCREV}"
-PV_colibri-t30 = "${PR}+gitr${SRCREV}"
-PV_apalis-t30 = "${PR}+gitr${SRCREV}"
-
-SRC_URI_colibri-t20 = "${SRC_URI_COLIBRI}"
-SRC_URI_colibri-t30 = "${SRC_URI_COLIBRI}"
-SRC_URI_apalis-t30 = "${SRC_URI_COLIBRI}"
-
-SRCREV_colibri-t20 = "${SRCREV_COLIBRI}"
-SRCREV_colibri-t30 = "${SRCREV_COLIBRI}"
-SRCREV_apalis-t30 = "${SRCREV_COLIBRI}"
-
-# override the solution passed in from u-boot.inc as we want to set additional flags
-EXTRA_OEMAKE_colibri-t20 = "CROSS_COMPILE=${TARGET_PREFIX}"
-EXTRA_OEMAKE_colibri-t30 = "CROSS_COMPILE=${TARGET_PREFIX}"
-EXTRA_OEMAKE_apalis-t30 = "CROSS_COMPILE=${TARGET_PREFIX}"
-
-# colibri-t20: build additionally a u-boot binary which uses/stores its environment on an T20 external sd or mmc card
-SPL_BINARY_colibri-t20 = "u-boot-hsmmc.bin"
-SPL_IMAGE_colibri-t20 = "u-boot-hsmmc-${MACHINE}-${PV}-${PR}.bin"
-SPL_SYMLINK_colibri-t20 = "u-boot-hsmmc-${MACHINE}.bin"
-do_compile_append_colibri-t20() {
- # keep u-boot-nand
- mv u-boot.bin u-boot-nand.bin
- oe_runmake colibri_t20_sdboot_config
- oe_runmake ${UBOOT_MAKE_TARGET}
- mv u-boot.bin u-boot-hsmmc.bin
- mv u-boot-nand.bin u-boot.bin
-}
-
-#do_install_append() {
-#}