summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-06-12 14:20:25 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2012-06-12 14:20:25 +0200
commitb3f0841ade3dc1cbd1b7dd825439cb03a02629d2 (patch)
tree1b3204eabb54494b91d8579fbb7d2e556a2ec245
parent5f8b970f28d6ca6c2173b3deda0c0dafe5d9d466 (diff)
- mklibs is no longer downloadable in the 0.1.33 version, upgrade to next version
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.06.bbappend37
-rw-r--r--recipes-devtools/mklibs/files/ac_init_fix.patch19
-rw-r--r--recipes-devtools/mklibs/files/fix_STT_GNU_IFUNC.patch26
-rw-r--r--recipes-devtools/mklibs/files/include-unistd.h-for-gcc47.patch43
-rw-r--r--recipes-devtools/mklibs/mklibs-native_0.1.34.bb26
-rw-r--r--recipes/images/angstrom-lxde-image.bb6
-rw-r--r--recipes/images/angstrom-lxde-image.bb~103
7 files changed, 139 insertions, 121 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2011.06.bbappend b/recipes-bsp/u-boot/u-boot_2011.06.bbappend
index 995c772..a110b0a 100644
--- a/recipes-bsp/u-boot/u-boot_2011.06.bbappend
+++ b/recipes-bsp/u-boot/u-boot_2011.06.bbappend
@@ -18,29 +18,34 @@ DEFAULT_PREFERENCE_colibri-t30 = "1"
UBOOT_MACHINE_colibri-t20 = "colibri_t20_config"
UBOOT_MACHINE_colibri-t30 = "colibri_t30_config"
-#gitorious git
-FILESPATHPKG =. "git:"
-S="${WORKDIR}/git"
-SRC_URI_COLIBRI = "git://gitorious.org/colibri-t20-embedded-linux-bsp/colibri_t20-u-boot.git;protocol=git;branch=master \
- file://u-boot-warning.patch \
- file://u-boot-board-unused.patch \
- file://board_stackcorruption_workaround.patch \
-"
-
-SRCREV_colibri-t20 = "63c37d9e1d3ea97391576384d237728c44b5e33b"
-SRCREV_colibri-t30 = "63c37d9e1d3ea97391576384d237728c44b5e33b"
+# gitorious git ###################################################################################################
+#FILESPATHPKG =. "git:"
+#S="${WORKDIR}/git"
+#SRC_URI_COLIBRI = "git://gitorious.org/colibri-t20-embedded-linux-bsp/colibri_t20-u-boot.git;protocol=git;branch=master \
+# file://u-boot-warning.patch \
+# file://u-boot-board-unused.patch \
+# file://board_stackcorruption_workaround.patch \
+#"
+#SRCREV_COLIBRI = "63c37d9e1d3ea97391576384d237728c44b5e33b"
+#####################################################################################################################
PV_colibri-t20 = "${PR}+gitr${SRCREV}"
PV_colibri-t30 = "${PR}+gitr${SRCREV}"
-#internal SVN
-#S = "${WORKDIR}/bootloader/u-boot"
-#SVN_REV = 218
-#SRC_URI_COLIBRI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=bootloader/u-boot;rev=${SVN_REV};proto=http \
-# file://remove-unused.patch "
+# internal SVN #####################################################################################################################
+S = "${WORKDIR}/bootloader/u-boot"
+SRCREV_COLIBRI = "298"
+SRC_URI_COLIBRI = "svn://tegradev:tegra123!@mammut.toradex.int:8090/colibri_tegra_linux/trunk;module=bootloader/u-boot;rev=${SRCREV_COLIBRI};proto=http \
+"
+#####################################################################################################################
SRC_URI_colibri-t20 = "${SRC_URI_COLIBRI} "
SRC_URI_colibri-t30 = "${SRC_URI_COLIBRI} "
+SRCREV_colibri-t20 = "${SRCREV_COLIBRI}"
+SRCREV_colibri-t30 = "${SRCREV_COLIBRI}"
+PV_colibri-t20 = "${PR}+gitr${SRCREV}"
+PV_colibri-t30 = "${PR}+gitr${SRCREV}"
+
#compile with -O2 not -Os as with gcc 4.5 the code does not work
# override the solution passed in from u-boot.inc as we want to set additional flags
diff --git a/recipes-devtools/mklibs/files/ac_init_fix.patch b/recipes-devtools/mklibs/files/ac_init_fix.patch
new file mode 100644
index 0000000..422af10
--- /dev/null
+++ b/recipes-devtools/mklibs/files/ac_init_fix.patch
@@ -0,0 +1,19 @@
+Get the version of mklibs by simpler means. The MKLIBS_VERSION string in the
+configure.ac file is replaced with real version string by the
+do_configure_prepend() function from the recipe .bb file.
+
+Upstream-Status: Inappropriate [configuration]
+
+Nitin A Kamble <nitin.a.kamble@intel.com>
+Date: 2011/01/24
+
+Index: mklibs/configure.ac
+===================================================================
+--- mklibs.orig/configure.ac 2010-02-21 17:34:56.000000000 -0800
++++ mklibs/configure.ac 2011-01-24 18:52:19.943242079 -0800
+@@ -1,4 +1,4 @@
+-AC_INIT([mklibs],m4_esyscmd(dpkg-parsechangelog | perl -ne 'print $1 if m/^Version: (.*)$/;'))
++AC_INIT([mklibs], MKLIBS_VERSION)
+ AM_INIT_AUTOMAKE([foreign no-define])
+ AC_CONFIG_HEADERS([config.h])
+ AM_MAINTAINER_MODE
diff --git a/recipes-devtools/mklibs/files/fix_STT_GNU_IFUNC.patch b/recipes-devtools/mklibs/files/fix_STT_GNU_IFUNC.patch
new file mode 100644
index 0000000..d27a489
--- /dev/null
+++ b/recipes-devtools/mklibs/files/fix_STT_GNU_IFUNC.patch
@@ -0,0 +1,26 @@
+The libc6-dev in Ubuntu 9.04 is so old that the elf.h doesn't
+define STT_GNU_IFUNC, so we have to define it ourselves.
+
+Upstream-Status: Inappropriate [other] - old release specific, maybe removable
+
+-- Dexuan Cui (dexuan.cui@intel.com) Feb 16, 2011.
+
+diff --git a/src/mklibs-readelf/main.cpp b/src/mklibs-readelf/main.cpp
+index 2444c39..56d93f8 100644
+--- a/src/mklibs-readelf/main.cpp
++++ b/src/mklibs-readelf/main.cpp
+@@ -6,6 +6,14 @@
+ #include <vector>
+
+ #include <elf.h>
++/*
++ * The /usr/include/elf.h in some distributions(like Ubuntu 9.04) doesn't
++ * define the macro. We need to define it here.
++ */
++#ifndef STT_GNU_IFUNC
++#define STT_GNU_IFUNC 10 /* Symbol is indirect code object */
++#endif
++
+ #include <getopt.h>
+
+ #include "elf.hpp"
diff --git a/recipes-devtools/mklibs/files/include-unistd.h-for-gcc47.patch b/recipes-devtools/mklibs/files/include-unistd.h-for-gcc47.patch
new file mode 100644
index 0000000..baa12bd
--- /dev/null
+++ b/recipes-devtools/mklibs/files/include-unistd.h-for-gcc47.patch
@@ -0,0 +1,43 @@
+include <unistd.h> to fix build on gcc 4.7
+
+Many of the standard C++ library include files have been edited to no
+longer include <unistd.h> to remove namespace pollution in gcc 4.7, so
+we need include <unistd.h> manually sometimes.
+
+mklibs (0.1.33+nmu1) UNRELEASED; urgency=low
+ * Non-maintainer upload
+ * Fix FTBFS with gcc 4.7 due to missing <unistd.h> include (Closes: #667282).
+
+-- Cyril Brulebois <kibi@debian.org> Thu, 05 Apr 2012 00:15:27 +0000
+
+mklibs (0.1.33) unstable; urgency=low
+
+ * Adjust the libc_pic directory for multiarch as well.
+
+Upstream-Status: Backport
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+
+[Added upstream information about patch]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+---
+ src/mklibs-readelf/elf.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/mklibs-readelf/elf.cpp b/src/mklibs-readelf/elf.cpp
+index 444f330..654c46f 100644
+--- a/src/mklibs-readelf/elf.cpp
++++ b/src/mklibs-readelf/elf.cpp
+@@ -25,6 +25,7 @@
+ #include <fcntl.h>
+ #include <sys/mman.h>
+ #include <sys/stat.h>
++#include <unistd.h>
+
+ using namespace Elf;
+
+--
+1.7.10
+
diff --git a/recipes-devtools/mklibs/mklibs-native_0.1.34.bb b/recipes-devtools/mklibs/mklibs-native_0.1.34.bb
new file mode 100644
index 0000000..5174f70
--- /dev/null
+++ b/recipes-devtools/mklibs/mklibs-native_0.1.34.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "mklibs produces cut-down shared libraries that contain only the routines required by a particular set of executables."
+HOMEPAGE = "https://code.launchpad.net/mklibs"
+SECTION = "devel"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=98d31037b13d896e33890738ef01af64"
+DEPENDS = "python-native"
+
+PR = "r1"
+
+SRC_URI = "http://ftp.de.debian.org/debian/pool/main/m/mklibs/${BPN}_${PV}.tar.gz \
+ file://ac_init_fix.patch\
+ file://fix_STT_GNU_IFUNC.patch\
+"
+# file://include-unistd.h-for-gcc47.patch \
+#"
+
+SRC_URI[md5sum] = "afe0ed527ba96b8a882b5de350603007"
+SRC_URI[sha256sum] = "0c13c314f5c397529f58a5a02d57d83aeb4463d6a0d80b9374c6576ec37ed39f"
+
+S = "${WORKDIR}/${BPN}-${PV}"
+
+inherit autotools gettext native
+
+do_configure_prepend() {
+ sed "s+MKLIBS_VERSION+${PV}+" ${S}/configure.ac
+}
diff --git a/recipes/images/angstrom-lxde-image.bb b/recipes/images/angstrom-lxde-image.bb
index 1b7b314..4ca8136 100644
--- a/recipes/images/angstrom-lxde-image.bb
+++ b/recipes/images/angstrom-lxde-image.bb
@@ -16,6 +16,7 @@ IMAGE_PREPROCESS_COMMAND = "rootfs_update_timestamp"
# xorg-minimal-fonts xserver-xorg-multimedia-modules xerver-xorg-utils xrandr
IMAGE_SPLASH = "psplash-angstrom"
+PREFERRED_PROVIDER_psplash-support = "psplash-angstrom"
DISTRO_UPDATE_ALTERNATIVES ??= ""
ROOTFS_PKGMANAGE_PKGS ?= '${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "${ROOTFS_PKGMANAGE} ${DISTRO_UPDATE_ALTERNATIVES}", d)}'
@@ -48,6 +49,7 @@ IMAGE_INSTALL += " \
task-basic \
${CONMANPKGS} \
${ROOTFS_PKGMANAGE_PKGS} \
+ timestamp-service \
task-base-extended \
${IMAGE_SPLASH} \
${XSERVER} \
@@ -93,8 +95,8 @@ include lx.inc
include trdx-extra.inc
IMAGE_DEV_MANAGER = "udev"
-IMAGE_INIT_MANAGER = "sysvinit sysvinit-pidof"
-IMAGE_INITSCRIPTS = "initscripts"
+IMAGE_INIT_MANAGER = "systemd"
+IMAGE_INITSCRIPTS = " "
IMAGE_LOGIN_MANAGER = "tinylogin shadow"
export IMAGE_BASENAME = "LXDE-image"
diff --git a/recipes/images/angstrom-lxde-image.bb~ b/recipes/images/angstrom-lxde-image.bb~
deleted file mode 100644
index 8e39f51..0000000
--- a/recipes/images/angstrom-lxde-image.bb~
+++ /dev/null
@@ -1,103 +0,0 @@
-#Angstrom image
-DESCRIPTION = "Image based on the LXDE desktop"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-
-#create the file /etc/timestamp
-IMAGE_PREPROCESS_COMMAND = "rootfs_update_timestamp"
-
-#IMAGE_LINGUAS = ""
-#IMAGE_LINGUAS = "en-us"
-#IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
-#ROOTFS_POSTPROCESS_COMMAND += 'install_linguas; '
-
-#MAYBE WE WILL NEED THESE ALSO:
-# xorg-minimal-fonts xserver-xorg-multimedia-modules xerver-xorg-utils xrandr
-
-IMAGE_SPLASH = "psplash-angstrom"
-
-DISTRO_UPDATE_ALTERNATIVES ??= ""
-ROOTFS_PKGMANAGE_PKGS ?= '${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "${ROOTFS_PKGMANAGE} ${DISTRO_UPDATE_ALTERNATIVES}", d)}'
-
-CONMANPKGS ?= "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-systemd"
-CONMANPKGS_libc-uclibc = ""
-
-DEPENDS += "gst-plugins-good gst-plugins-bad gst-plugins-ugly"
-
-# Additional X libs not pulled in by any package \
-# xtrans libxdamage libxvmc libxinerama libxevie \
-
-# Required for starting X but not RDEPEND by the using package \
-# libxcursor \
-
-# glib-2.0 has some additional packages which are not pulled in, let's do this here \
-# gobject-2.0 gmodule-2.0 gthread-2.0 gio-2.0 \
-
-# this would pull in a large amount of gst-plugins, we only add a selected few
-# gst-plugins-base-meta \
-# gst-plugins-good-meta \
-# gst-plugins-bad-meta \
-# gst-ffmpeg \
-
-# needed by nvidia commandline player \
-# libpcre \
-
-IMAGE_INSTALL += " \
- angstrom-task-boot \
- task-basic \
- ${CONMANPKGS} \
- ${ROOTFS_PKGMANAGE_PKGS} \
- task-base-extended \
- ${IMAGE_SPLASH} \
- ${XSERVER} \
- \
- libxdamage libxvmc libxinerama \
- libxcursor \
- xtrans \
- \
- bash \
- tinylogin \
- \
- gstreamer \
- gst-plugins-base \
- gst-plugins-base-alsa \
- gst-plugins-base-audioconvert \
- gst-plugins-base-audioresample \
- gst-plugins-base-audiotestsrc \
- gst-plugins-base-decodebin \
- gst-plugins-base-decodebin2 \
- gst-plugins-base-playbin \
- gst-plugins-base-typefindfunctions \
- gst-plugins-base-ivorbisdec \
- gst-plugins-base-ogg \
- gst-plugins-base-theora \
- gst-plugins-base-videotestsrc \
- gst-plugins-base-vorbis \
- gst-plugins-good-matroska \
- gst-plugins-good-rtp \
- gst-plugins-good-udp \
- gst-plugins-good-avi \
- gst-plugins-good-wavenc \
- gst-plugins-good-wavparse \
- gst-plugins-ugly-asf \
- libpcre \
- libxcomposite \
- firefox \
- flash-plugins \
-"
-#libxevie
-# gst-plugin-qtdemux \
-# gst-plugin-mpegdemux \
-
-include lx.inc
-include trdx-extra.inc
-
-IMAGE_DEV_MANAGER = "udev"
-IMAGE_INIT_MANAGER = "sysvinit sysvinit-pidof"
-IMAGE_INITSCRIPTS = "initscripts"
-IMAGE_LOGIN_MANAGER = "tinylogin shadow"
-
-export IMAGE_BASENAME = "LXDE-image"
-
-inherit image