summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-09-02 20:59:56 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-09-22 12:23:56 +0200
commite982465a526fcc85ad61e8244c9c3ac5e07537c5 (patch)
tree0f5e4f7977693add858bd82790d76a6c2b6b70c2
parent4249efbb355f99dcfa90d5012eea258db57d8e49 (diff)
images: use consistent image names
- use consistent image names - while at it build the GLES samples only for a tegra machine
-rw-r--r--recipes/images/angstrom-lxde-image.bb11
-rw-r--r--recipes/images/angstrom-qt-x11-image.bb9
-rw-r--r--recipes/images/console-trdx-image.bb9
3 files changed, 18 insertions, 11 deletions
diff --git a/recipes/images/angstrom-lxde-image.bb b/recipes/images/angstrom-lxde-image.bb
index efd119c..d1792f2 100644
--- a/recipes/images/angstrom-lxde-image.bb
+++ b/recipes/images/angstrom-lxde-image.bb
@@ -7,11 +7,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
PV = "V2.1"
PR = "r5"
-#start of the resulting deployable tarball
-IMAGE_NAME_colibri-t20 = "T20_LinuxImage"
-IMAGE_NAME_colibri-t30 = "T30_LinuxImage"
+#start of the resulting deployable tarball name
+IMAGE_NAME_colibri-t20 = "Colibri_T20_LinuxImage"
+IMAGE_NAME_colibri-t30 = "Colibri_T30_LinuxImage"
IMAGE_NAME_apalis-t30 = "Apalis_T30_LinuxImage"
-IMAGE_NAME_colibri-pxa = "PXA_LinuxImage"
+IMAGE_NAME_colibri-pxa = "Colibri_PXA_LinuxImage"
+IMAGE_NAME = "${MACHINE}_LinuxImage"
#create the deployment directory-tree
require trdx-image-fstype.inc
@@ -41,7 +42,7 @@ CONMANPKGS_libc-uclibc = ""
DEPENDS += "gst-plugins-good gst-plugins-bad gst-plugins-ugly"
#deploy the OpenGL ES headers to the sysroot
-DEPENDS += "nvsamples"
+DEPENDS_tegra += "nvsamples"
#build some ipk which are needed together with CAN, but do not yet install them
DEPENDS += "canutils libsocketcan iproute2"
diff --git a/recipes/images/angstrom-qt-x11-image.bb b/recipes/images/angstrom-qt-x11-image.bb
index 6774ca6..1bb2cc0 100644
--- a/recipes/images/angstrom-qt-x11-image.bb
+++ b/recipes/images/angstrom-qt-x11-image.bb
@@ -4,14 +4,15 @@ DESCRIPTION = "Image based on qt4-x11-free"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PV = "V2.0"
+PV = "V2.1"
PR = "r3"
#start of the resulting deployable tarball name
-IMAGE_NAME_colibri-t20 = "T20_LinuxImage-qt"
-IMAGE_NAME_colibri-t30 = "T30_LinuxImage-qt"
+IMAGE_NAME_colibri-t20 = "Colibri_T20_LinuxImage-qt"
+IMAGE_NAME_colibri-t30 = "Colibri_T30_LinuxImage-qt"
IMAGE_NAME_apalis-t30 = "ApalisT30_LinuxImage-qt"
IMAGE_NAME_colibri-pxa = "PXA_LinuxImage-qt"
+IMAGE_NAME = "${MACHINE}_LinuxImage-qt"
#create the deployment directory-tree
require trdx-image-fstype.inc
@@ -34,7 +35,7 @@ CONMANPKGS_libc-uclibc = ""
DEPENDS += "gst-plugins-good gst-plugins-bad gst-plugins-ugly"
#deploy the OpenGL ES headers to the sysroot
-DEPENDS += "nvsamples"
+DEPENDS_tegra += "nvsamples"
#build some ipk which are needed together with CAN, but do not yet install them
DEPENDS += "canutils libsocketcan iproute2"
diff --git a/recipes/images/console-trdx-image.bb b/recipes/images/console-trdx-image.bb
index c261433..1fd0dce 100644
--- a/recipes/images/console-trdx-image.bb
+++ b/recipes/images/console-trdx-image.bb
@@ -1,12 +1,17 @@
#Angstrom image
DESCRIPTION = "Image booting to a console"
-IMAGE_NAME = "${MACHINE}-console-trdx-image"
+#start of the resulting deployable tarball name
+IMAGE_NAME_colibri-t20 = "Colibri_T20_LinuxConsoleImage"
+IMAGE_NAME_colibri-t30 = "Colibri_T30_LinuxConsoleImage"
+IMAGE_NAME_apalis-t30 = "Apalis_T30_LinuxConsoleImage"
+IMAGE_NAME_colibri-pxa = "Colibri_PXA_LinuxConsoleImage"
+IMAGE_NAME = "${MACHINE}_LinuxConsoleImage"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PV = "ConsoleV2.0"
+PV = "V2.1"
PR = "r3"
#create the deployment directory-tree