summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-05-26 13:21:15 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 13:44:04 +0100
commit74ff9d08bc047ef5a53c98213930ae25d3444114 (patch)
tree012e926681f421547ef075fb6fb00ff8551a4bf5
parent6ef3d172e889412ce0d09634fc6c62e284821b76 (diff)
lxqt-themes: split postinst into build time and boot
upstream added an ontarget postinst routine rather than postinst returning not 0 for code which should run on target. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--meta-qt5-extra/recipes-lxqt/lxqt-themes/lxqt-themes_%.bbappend21
1 files changed, 4 insertions, 17 deletions
diff --git a/meta-qt5-extra/recipes-lxqt/lxqt-themes/lxqt-themes_%.bbappend b/meta-qt5-extra/recipes-lxqt/lxqt-themes/lxqt-themes_%.bbappend
index c4dee8e..784b958 100644
--- a/meta-qt5-extra/recipes-lxqt/lxqt-themes/lxqt-themes_%.bbappend
+++ b/meta-qt5-extra/recipes-lxqt/lxqt-themes/lxqt-themes_%.bbappend
@@ -41,11 +41,7 @@ do_install_append () {
ln -sf ${WALLPAPER-MACHINE} ${D}/${datadir}/lxqt/themes/toradex/toradex.png
}
-pkg_postinst_${PN}_vf () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
+pkg_postinst_ontarget_${PN}_vf () {
IS_VF50=`grep -c VF50 /proc/cpuinfo`
IS_VF50_DTB=`grep -c toradex,vf500-colibri_vf50 /proc/device-tree/compatible`
IS_VF61=`grep -c VF61 /proc/cpuinfo`
@@ -57,11 +53,7 @@ pkg_postinst_${PN}_vf () {
fi
}
-pkg_postinst_${PN}_mx6 () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
+pkg_postinst_ontarget_${PN}_mx6 () {
SOC_TYPE=`cat /sys/bus/soc/devices/soc0/soc_id`
CORES=`grep -c processor /proc/cpuinfo`
case $CORES in
@@ -87,15 +79,11 @@ pkg_postinst_${PN}_mx6 () {
# the ull is in the mx6 soc family, so give a more specific override here
# do nothing, but do not prevent the injected update-alternatives to run on
# the target.
-pkg_postinst_${PN}_mx6ull () {
+pkg_postinst_ontarget_${PN}_mx6ull () {
:
}
-pkg_postinst_${PN}_mx7 () {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
+pkg_postinst_ontarget_${PN}_mx7 () {
# Currently the soc bus subsystem seems not to work on i.MX 7Solo
# SOC_TYPE=`cat /sys/bus/soc/devices/soc0/soc_id`
# if [ "x$SOC_TYPE" = "xi.MX7D" ]; then
@@ -115,5 +103,4 @@ pkg_postinst_${PN}_mx7 () {
ln -sf Wallpaper_Toradex.png ${datadir}/lxqt/themes/toradex/toradex.png
;;
esac
-
}