summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-12-26 17:33:18 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2020-01-09 19:49:30 +0100
commitda3dfd8138787574cf3a558ff76340f086f34c0d (patch)
tree084daabb94b4e23e4d674c4ed2c48c15790c08b8
parent07eef25600cf5663f2b5881d0e9570147915da67 (diff)
spidev-test: add recipe
Related-to: ELB-1284 Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-devtools/spidev-test/spidev-test.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-devtools/spidev-test/spidev-test.bb b/recipes-devtools/spidev-test/spidev-test.bb
new file mode 100644
index 0000000..8ce252a
--- /dev/null
+++ b/recipes-devtools/spidev-test/spidev-test.bb
@@ -0,0 +1,17 @@
+SUMMARY = "The Linux kernels spidev-test programm"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+S = "${WORKDIR}"
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+
+do_compile () {
+ ${CC} ${STAGING_KERNEL_DIR}/tools/spi/spidev_test.c -o spidev_test
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/spidev_test ${D}${bindir}/
+}