summaryrefslogtreecommitdiff
path: root/recipes-bsp/mqxboot/mqxboot_1.0.bb
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2014-03-26 10:41:40 +0100
committerStefan Agner <stefan.agner@toradex.com>2014-03-26 10:46:45 +0100
commita8d0bc3acdece0ead6c511c883fe52e56de01dc2 (patch)
treef2c71ad044c8f359222b838e8b3fbeaa96e66e2c /recipes-bsp/mqxboot/mqxboot_1.0.bb
parentf3ed049ae8244b1550cfa54bd4605daf7910cd9e (diff)
mqxboot/libmcc: fixed dependencies to kernel module
We need to have the kernel modules header at build time, so mark it as not only a runtime dependency.
Diffstat (limited to 'recipes-bsp/mqxboot/mqxboot_1.0.bb')
-rw-r--r--recipes-bsp/mqxboot/mqxboot_1.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-bsp/mqxboot/mqxboot_1.0.bb b/recipes-bsp/mqxboot/mqxboot_1.0.bb
index 17f0233..f7b6348 100644
--- a/recipes-bsp/mqxboot/mqxboot_1.0.bb
+++ b/recipes-bsp/mqxboot/mqxboot_1.0.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "Timesys MQX Image loader - starts an MQX image on the M4"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c49712341497d0b5f2e40c30dff2af9d"
-RDEPENDS_${PN} = "kernel-module-mcc"
+DEPENDS = "kernel-module-mcc"
inherit autotools
@@ -15,4 +15,8 @@ SRC_URI[sha256sum] = "c2f66ae962fe2529578d5c007e3f91a36085b714a0ea276f47bc3aea90
S = "${WORKDIR}/mqxboot-${PV}"
+CFLAGS += "-I${STAGING_KERNEL_DIR}/include"
+
+RDEPENDS_${PN} = "kernel-module-mcc"
+
COMPATIBLE_MACHINE = "(vf60)"