summaryrefslogtreecommitdiff
path: root/recipes-core/systemd/systemd_%.bbappend
diff options
context:
space:
mode:
authorStefan Agner <stefan.agner@toradex.com>2015-04-29 18:41:01 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2015-05-12 10:06:07 +0200
commit18df6079ce7362b95b7c6ad68a0c30777aa521b4 (patch)
tree102837203809b92a710d4cdc40509d952da4e723 /recipes-core/systemd/systemd_%.bbappend
parente8ef5655f4854cb08d26330e5f87738255261234 (diff)
systemd: add networkd for RNDIS configuration
Since Connman is better suited for more advanced Wireless solutions, we keep Connman for the main network configuration manager. However, for the simple RNDIS debug/test configuration, Connman is not well suited since Connman tries to maintain one connection only at any given time. This change enables networkd and adds a simple standard configuration for USB/RNDIS network devices.
Diffstat (limited to 'recipes-core/systemd/systemd_%.bbappend')
-rw-r--r--recipes-core/systemd/systemd_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-core/systemd/systemd_%.bbappend b/recipes-core/systemd/systemd_%.bbappend
index b24e14c..df69043 100644
--- a/recipes-core/systemd/systemd_%.bbappend
+++ b/recipes-core/systemd/systemd_%.bbappend
@@ -2,6 +2,17 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/systemd:"
SRC_URI += " \
file://networkd_dont_stop_the_dhcp_server.patch \
+ file://rndis.network \
"
PACKAGECONFIG_append = " networkd"
+
+do_install_append() {
+ # The network files need to be in /usr/lib/systemd, not ${systemd_unitdir}...
+ install -d ${D}${prefix}/lib/systemd/network/
+ install -m 0644 ${WORKDIR}/rndis.network ${D}${prefix}/lib/systemd/network/
+}
+
+FILES_${PN} += " \
+ ${nonarch_base_libdir}/systemd/network \
+"