summaryrefslogtreecommitdiff
path: root/recipes-core/systemd/timestamp-service.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-01-07 19:41:45 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2019-03-06 13:46:01 +0100
commitc1c098080b8ab5b3c612d4a86c03bdade69fe3e8 (patch)
tree4f5a20a206cf9fb246fbcc9c185712241713a4d3 /recipes-core/systemd/timestamp-service.bb
parent79c612b3ce834afeb1d1948ef76381c2cf52ce91 (diff)
timestamp-service: import from angstrom
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-core/systemd/timestamp-service.bb')
-rw-r--r--recipes-core/systemd/timestamp-service.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-core/systemd/timestamp-service.bb b/recipes-core/systemd/timestamp-service.bb
new file mode 100644
index 0000000..b1d4902
--- /dev/null
+++ b/recipes-core/systemd/timestamp-service.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Poor mans RTC using timestamps"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit allarch systemd
+
+SRC_URI = "file://timestamp.service \
+ file://load-timestamp.sh \
+ "
+
+do_compile() {
+ :
+}
+
+
+do_install () {
+ install -d ${D}/${bindir}
+
+ install -m 0755 ${WORKDIR}/load-timestamp.sh ${D}/${bindir}
+
+ install -d ${D}/${base_libdir}/systemd/system
+ install -m 0644 ${WORKDIR}/timestamp.service ${D}/${base_libdir}/systemd/system/
+}
+
+NATIVE_SYSTEMD_SUPPORT = "1"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "timestamp.service"
+
+FILES_${PN} += "${base_libdir}/systemd"
+