summaryrefslogtreecommitdiff
path: root/recipes-core
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-07-25 19:39:32 +0200
committerStefan Agner <stefan.agner@toradex.com>2016-09-28 13:27:17 -0700
commit1a63d646e642b27cae88bcd6839b1a5e63e921bc (patch)
tree897b91acc497df25a32cf9eed9854f1af59827dd /recipes-core
parent4ea9cfba51198803c102fc09c0d5804e74ec4f13 (diff)
base-files: mv all files into recipes-core/base-files
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/base-files/base-files/fstab12
-rw-r--r--recipes-core/base-files/base-files/inputrc61
-rw-r--r--recipes-core/base-files/base-files/profile41
-rw-r--r--recipes-core/base-files/base-files_3.0.14.bbappend7
4 files changed, 121 insertions, 0 deletions
diff --git a/recipes-core/base-files/base-files/fstab b/recipes-core/base-files/base-files/fstab
new file mode 100644
index 0000000..739b844
--- /dev/null
+++ b/recipes-core/base-files/base-files/fstab
@@ -0,0 +1,12 @@
+# stock fstab - you probably want to override this with a machine specific one
+
+/dev/root / auto defaults 1 1
+proc /proc proc defaults 0 0
+devpts /dev/pts devpts mode=0620,gid=5 0 0
+usbdevfs /proc/bus/usb usbdevfs noauto 0 0
+tmpfs /run tmpfs mode=0755,nodev,nosuid,strictatime 0 0
+tmpfs /var/volatile tmpfs defaults 0 0
+
+# uncomment this if your device has a SD/MMC/Transflash slot
+#/dev/mmcblk0p1 /media/card auto defaults,sync,noauto 0 0
+
diff --git a/recipes-core/base-files/base-files/inputrc b/recipes-core/base-files/base-files/inputrc
new file mode 100644
index 0000000..4a2874b
--- /dev/null
+++ b/recipes-core/base-files/base-files/inputrc
@@ -0,0 +1,61 @@
+# /etc/inputrc - global inputrc for libreadline
+# See readline(3readline) and `info rluserman' for more information.
+
+# Be 8 bit clean.
+set input-meta on
+set output-meta on
+
+# To allow the use of 8bit-characters like the german umlauts, comment out
+# the line below. However this makes the meta key not work as a meta key,
+# which is annoying to those which don't need to type in 8-bit characters.
+
+# set convert-meta off
+
+# try to enable the application keypad when it is called. Some systems
+# need this to enable the arrow keys.
+# set enable-keypad on
+
+# see /usr/share/doc/bash/inputrc.arrows for other codes of arrow keys
+
+# do not bell on tab-completion
+# set bell-style none
+
+# some defaults / modifications for the emacs mode
+$if mode=emacs
+
+# allow the use of the Home/End keys
+"\e[1~": beginning-of-line
+"\e[4~": end-of-line
+
+# allow the use of the Delete/Insert keys
+"\e[3~": delete-char
+"\e[2~": quoted-insert
+
+# mappings for "page up" and "page down" to step to the beginning/end
+# of the history
+# "\e[5~": beginning-of-history
+# "\e[6~": end-of-history
+
+# alternate mappings for "page up" and "page down" to search the history
+# "\e[5~": history-search-backward
+# "\e[6~": history-search-forward
+
+# # mappings for Ctrl-left-arrow and Ctrl-right-arrow for word moving
+# "\e[5C": forward-word
+# "\e[5D": backward-word
+# "\e\e[C": forward-word
+# "\e\e[D": backward-word
+
+# $if term=rxvt
+# "\e[8~": end-of-line
+# $endif
+
+# for non RH/Debian xterm, can't hurt for RH/DEbian xterm
+# "\eOH": beginning-of-line
+# "\eOF": end-of-line
+
+# for freebsd console
+# "\e[H": beginning-of-line
+# "\e[F": end-of-line
+
+$endif
diff --git a/recipes-core/base-files/base-files/profile b/recipes-core/base-files/base-files/profile
new file mode 100644
index 0000000..7b8b80d
--- /dev/null
+++ b/recipes-core/base-files/base-files/profile
@@ -0,0 +1,41 @@
+# /etc/profile: system-wide .profile file for the Bourne shell (sh(1))
+# and Bourne compatible shells (bash(1), ksh(1), ash(1), ...).
+
+PATH="/usr/local/bin:/usr/bin:/bin"
+EDITOR="/bin/vi" # needed for packages like cron
+test -z "$TERM" && TERM="vt100" # Basic terminal capab. For screen etc.
+
+if [ ! -e /etc/localtime ]; then
+ TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
+ # for an explanation of how to set this to your local timezone.
+ export TZ
+fi
+
+if [ "$HOME" = "/home/root" ]; then
+ PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin
+fi
+if [ "$PS1" ]; then
+# works for bash and ash (no other shells known to be in use here)
+ PS1='\u@\h:\w\$ '
+fi
+
+if [ -d /etc/profile.d ]; then
+ for i in /etc/profile.d/* ; do
+ . $i
+ done
+ unset i
+fi
+
+test -z "$DISPLAY" && DISPLAY=":0.0" # have the X display defined, unless it is already set, e.g. by a ssh connection
+export DISPLAY
+
+export PATH PS1 OPIEDIR QPEDIR QTDIR EDITOR TERM
+
+# Serial consoles are not able to autoresize. Set size once upon login.
+# Make sure we are on a serial console (i.e. the device used starts with /dev/tty),
+# otherwise we confuse e.g. the eclipse launcher which tries do use ssh
+LOGINDEV=`tty | cut -c1-8`
+test "$LOGINDEV" = "/dev/tty" && resize
+
+umask 022
+
diff --git a/recipes-core/base-files/base-files_3.0.14.bbappend b/recipes-core/base-files/base-files_3.0.14.bbappend
new file mode 100644
index 0000000..539a117
--- /dev/null
+++ b/recipes-core/base-files/base-files_3.0.14.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/base-files:"
+
+do_install_append () {
+ echo "search toradex.net" > ${D}${sysconfdir}/resolv.conf
+ echo "nameserver 8.8.8.8" >> ${D}${sysconfdir}/resolv.conf
+ echo "nameserver 8.8.4.4" >> ${D}${sysconfdir}/resolv.conf
+}