summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2016-06-16 21:56:55 +0200
committerStefan Agner <stefan.agner@toradex.com>2017-01-10 14:59:09 -0800
commitf925a2c3f2385ae8c21912d7ede29f2dacab6cfd (patch)
tree13d1a699482d4ef99c3f54681c18263d6df3789b /recipes-devtools
parentd78ebd07633e61fac1a0f699edb3529d9f25456a (diff)
python_2.7.9.bbappend: fix d.getVar call
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Stefan Agner <stefan.agner@toradex.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python_2.7.9.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-devtools/python/python_2.7.9.bbappend b/recipes-devtools/python/python_2.7.9.bbappend
index 64d3787..28e5d9e 100644
--- a/recipes-devtools/python/python_2.7.9.bbappend
+++ b/recipes-devtools/python/python_2.7.9.bbappend
@@ -12,8 +12,8 @@ SRC_URI += " \
${@bb.utils.contains('PACKAGECONFIG', 'tkinter', '', 'file://dont_build_tkinter.patch', d)} \
"
python __anonymous() {
- if not 'openembedded-layer' in d.getVar('BBFILE_COLLECTIONS'):
- if 'tkinter' in d.getVar('PACKAGECONFIG'):
+ if not 'openembedded-layer' in d.getVar('BBFILE_COLLECTIONS', True):
+ if 'tkinter' in d.getVar('PACKAGECONFIG', True):
bb.error('Python PACKAGECONFIG tkinter requires tk provided by' \
'meta-oe layer but the layer is not available.')
}