summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2015-02-12 09:06:27 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2015-02-12 09:06:27 +0100
commitf52691ba7ba4a3af978946246eaee20d9c07abc7 (patch)
treed3235f3588b7f63309285f72733124199826ae05 /recipes-devtools
parentca6be59e948fc1e028ba7cb94c4d5bcef32d7167 (diff)
mmc-utils: add recipe for chromiumos version thereof
Add a recipe for the Chromium OS version of the mmc-utils able to handle Extended CSD revision 1.7 of the latest MMC 5.0 specification. Some of the more interesting information thereof is the life time estimation and pre EOL information as follows: root@apalis-t30:~# mmc extcsd read /dev/mmcblk0 | \ grep -A 3 'Device life time estimation type A' Device life time estimation type A [DEVICE_LIFE_TIME_EST_TYP_A: 0x01] i.e. 0% - 10% device life time used Pre EOL information [PRE_EOL_INFO: 0x01] i.e. Normal
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/mmc/mmc-utils/0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch28
-rw-r--r--recipes-devtools/mmc/mmc-utils_chromiumos.bb19
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes-devtools/mmc/mmc-utils/0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch b/recipes-devtools/mmc/mmc-utils/0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch
new file mode 100644
index 0000000..1724de5
--- /dev/null
+++ b/recipes-devtools/mmc/mmc-utils/0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch
@@ -0,0 +1,28 @@
+Upstream-Status: Pending
+
+mmc.h: don't include <asm-generic/int-ll64.h>
+
+Including this file causes a compile failure for qemumips64.
+This file is not needed to be explicitly included, because it will be
+included by the <linux/mmc/ioctl.h> file if _MIPS_SZLONG is not 64.
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ mmc.h | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/mmc.h b/mmc.h
+index 9871d62..3df2cdf 100644
+--- a/mmc.h
++++ b/mmc.h
+@@ -14,7 +14,6 @@
+ * Boston, MA 021110-1307, USA.
+ */
+
+-#include <asm-generic/int-ll64.h>
+ #include <linux/mmc/ioctl.h>
+ #include <stdio.h>
+
+--
+1.7.9.5
+
diff --git a/recipes-devtools/mmc/mmc-utils_chromiumos.bb b/recipes-devtools/mmc/mmc-utils_chromiumos.bb
new file mode 100644
index 0000000..54dcaca
--- /dev/null
+++ b/recipes-devtools/mmc/mmc-utils_chromiumos.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Userspace tools for MMC/SD devices"
+HOMEPAGE = "http://git.kernel.org/cgit/linux/kernel/git/cjb/mmc-utils.git/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=17;md5=d7747fc87f1eb22b946ef819969503f0"
+
+BRANCH ?= "master"
+SRCREV = "eb1cd019c6ad425633a509ab3578e59d5c9ebbc5"
+
+PV = "0.1"
+
+SRC_URI = "git://chromium.googlesource.com/chromiumos/third_party/mmc-utils.git;protocol=https;branch=${BRANCH} \
+ file://0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 mmc ${D}${bindir}
+}