summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2021-02-23 15:52:43 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2021-02-23 15:58:52 +0100
commit8b6a847c7cd879f2d77452321eae3e0f5d8c6b41 (patch)
tree969c2f9b90fe04043047694f5d5465dc10f31f9d /recipes-devtools
parent0dcdfce72f14b76e789f7ad7465903c12ccef2a3 (diff)
spidev-test: drop support for older kernel and change license check
The source file in the kernel moved with kernel 4.5. Drop support for older kernels. Upstream commit 2456f523cf ("licenses: Update license file to match current SPDX names") deprecated the usage of GPL-2.0 SPDX identifier, removed GPL-2.0 license file and replaced it with GPL-2.0-only SPDX identifier and text file. Rather than pointing to the new generic file rework to check the license from the SPDX header in the source file. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/spidev-test/spidev-test.bb14
1 files changed, 3 insertions, 11 deletions
diff --git a/recipes-devtools/spidev-test/spidev-test.bb b/recipes-devtools/spidev-test/spidev-test.bb
index 3e0b1e1..b9d9ad9 100644
--- a/recipes-devtools/spidev-test/spidev-test.bb
+++ b/recipes-devtools/spidev-test/spidev-test.bb
@@ -1,24 +1,16 @@
SUMMARY = "The Linux kernels spidev-test programm"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://${STAGING_KERNEL_DIR}/${KERNELPATH};endline=1;md5=fcab174c20ea2e2bc0be64b493708266"
PACKAGE_ARCH = "${MACHINE_ARCH}"
S = "${WORKDIR}"
do_configure[depends] += "virtual/kernel:do_shared_workdir"
-# the spidev_test.c example got moved to tools/spi/ starting with
-# the v.4.5.y kernel
KERNELPATH = "tools/spi/spidev_test.c"
-KERNELPATH-OLD = "Documentation/spi/spidev_test.c"
do_compile () {
- if [ -f "${STAGING_KERNEL_DIR}/${KERNELPATH}" ]
- then
- ${CC} ${LDFLAGS} ${STAGING_KERNEL_DIR}/${KERNELPATH} -o spidev_test
- else
- ${CC} ${LDFLAGS} ${STAGING_KERNEL_DIR}/${KERNELPATH-OLD} -o spidev_test
- fi
+ ${CC} ${LDFLAGS} ${STAGING_KERNEL_DIR}/${KERNELPATH} -o spidev_test
}
do_install () {