summaryrefslogtreecommitdiff
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2015-12-26 13:57:02 +0100
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2016-09-29 06:31:16 +0200
commit99197f671cfffca7c201115a70265575b34b94d4 (patch)
tree5c2dd7c62cf266e523f9e2d19de5b5cb3eb37020 /recipes-devtools
parenta9b3111a10c87eb6c93b5bcbf2fefbecb1a53aa2 (diff)
recipes: stop using base_contains
The base_contains function is deprecated and we ought to use bb.utils.contains instead. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Acked-by: Marcel Ziswiler <marcel.ziswiler@toradex.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python_2.7.9.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-devtools/python/python_2.7.9.bbappend b/recipes-devtools/python/python_2.7.9.bbappend
index ff0071f..64d3787 100644
--- a/recipes-devtools/python/python_2.7.9.bbappend
+++ b/recipes-devtools/python/python_2.7.9.bbappend
@@ -7,9 +7,9 @@ PACKAGECONFIG ?= ""
PACKAGECONFIG[tkinter] = ",,tk"
PACKAGECONFIG_remove_class-native = "tkinter"
PACKAGECONFIG_remove_class-nativesdk = "tkinter"
-RDEPENDS_${PN}-tkinter_append += "${@base_contains('PACKAGECONFIG', 'tkinter', 'tcl tk', '', d)}"
+RDEPENDS_${PN}-tkinter_append += "${@bb.utils.contains('PACKAGECONFIG', 'tkinter', 'tcl tk', '', d)}"
SRC_URI += " \
- ${@base_contains('PACKAGECONFIG', 'tkinter', '', 'file://dont_build_tkinter.patch', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'tkinter', '', 'file://dont_build_tkinter.patch', d)} \
"
python __anonymous() {
if not 'openembedded-layer' in d.getVar('BBFILE_COLLECTIONS'):