summaryrefslogtreecommitdiff
path: root/recipes-graphics/scrot/giblib_1.2.4.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-04-25 10:42:33 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-04-25 10:42:33 +0200
commitf012b1617737c4b28d936c09ec699433c9b1ff4a (patch)
treee0002b9945f6f043420675ef531773309fdc7881 /recipes-graphics/scrot/giblib_1.2.4.bb
parent1c28f399c826107717d1d6925ab1910bc990eead (diff)
scrot: add scrot recipe, commandline screen capture utility
Diffstat (limited to 'recipes-graphics/scrot/giblib_1.2.4.bb')
-rw-r--r--recipes-graphics/scrot/giblib_1.2.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-graphics/scrot/giblib_1.2.4.bb b/recipes-graphics/scrot/giblib_1.2.4.bb
new file mode 100644
index 0000000..8a8428d
--- /dev/null
+++ b/recipes-graphics/scrot/giblib_1.2.4.bb
@@ -0,0 +1,30 @@
+SECTION = "graphic/utils"
+DESCRIPTION = "giblib is a simple library which wraps imlib2"
+HOMEPAGE = "http://linuxbrit.co.uk/software/"
+LICENSE ="BSD"
+RDEPENDS_${PN} = "imlib2"
+DEPENDS = "imlib2"
+
+SRC_URI = "http://linuxbrit.co.uk/downloads/giblib-${PV}.tar.gz \
+ file://fix-giblib-binconfig-paths.patch "
+LIC_FILES_CHKSUM = "file://COPYING;md5=dd3cb8d7a69f3d0b2a52a46c92389011"
+SRC_URI[md5sum] = "c810ef5389baf24882a1caca2954385e"
+SRC_URI[sha256sum] = "176611c4d88d742ea4013991ad54c2f9d2feefbc97a28434c0f48922ebaa8bac"
+
+PR = "r0"
+
+do_compile_prepend () {
+ #remove linkerpath to host libraries
+ sed -i -e 's:-L/usr/lib\s::' Makefile
+ sed -i -e 's:-L/usr/lib\s::' giblib/Makefile
+ export DESTDIR=${D}
+}
+
+do_compile_prepend () {
+ export DESTDIR=${D}
+}
+
+FILES_${PN}-doc = "/usr/doc"
+
+inherit autotools binconfig
+