summaryrefslogtreecommitdiff
path: root/recipes-graphics/vnc/tightvnc
diff options
context:
space:
mode:
authorMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-07-15 15:46:59 +0200
committerMarcel Ziswiler <marcel.ziswiler@toradex.com>2014-07-15 15:48:26 +0200
commitfa935091a733be1c6d472ef36dab2374887d4497 (patch)
treeabfa2006775340fed265adbe2df5d37423289c96 /recipes-graphics/vnc/tightvnc
parentda5646995614d88ad151b82da2072ed51f7ef0cd (diff)
vnc: add directvnc and tightvnc recipes
Two popular VNC clients: - DirectVNC based on DirectFB (e.g. without X11) - TightVNC based on X11 (cherry picked from commit ef4113208de357a5b8accd7610f8bf3230125a59)
Diffstat (limited to 'recipes-graphics/vnc/tightvnc')
-rw-r--r--recipes-graphics/vnc/tightvnc/Makefile24
-rw-r--r--recipes-graphics/vnc/tightvnc/Vncviewer66
2 files changed, 90 insertions, 0 deletions
diff --git a/recipes-graphics/vnc/tightvnc/Makefile b/recipes-graphics/vnc/tightvnc/Makefile
new file mode 100644
index 0000000..3f720f8
--- /dev/null
+++ b/recipes-graphics/vnc/tightvnc/Makefile
@@ -0,0 +1,24 @@
+OBJS = argsresources.o \
+caps.o \
+colour.o \
+cursor.o \
+desktop.o \
+dialogs.o \
+fullscreen.o \
+listen.o \
+misc.o \
+popup.o \
+rfbproto.o \
+selection.o \
+shm.o \
+sockets.o \
+tunnel.o \
+vncviewer.o \
+../libvncauth/vncauth.o \
+../libvncauth/d3des.o
+
+tightvncviewer : $(OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -lX11 -lXaw6 -ljpeg -lz -lXt -lXmu -lXext -o tightvncviewer
+
+%.o: %.c Makefile
+ $(CC) -c $(CFLAGS) -I. -I../include -I../libvncauth/ -o $@ $<
diff --git a/recipes-graphics/vnc/tightvnc/Vncviewer b/recipes-graphics/vnc/tightvnc/Vncviewer
new file mode 100644
index 0000000..ed60ecd
--- /dev/null
+++ b/recipes-graphics/vnc/tightvnc/Vncviewer
@@ -0,0 +1,66 @@
+Vncviewer.title: TightVNC: %s
+Vncviewer.translations:\
+ <Enter>: SelectionToVNC()\n\
+ <Leave>: SelectionFromVNC()
+*form.background: black
+*viewport.allowHoriz: True
+*viewport.allowVert: True
+*viewport.useBottom: True
+*viewport.useRight: True
+*viewport*Scrollbar*thumb: None
+*desktop.baseTranslations:\
+ <Key>F8: ShowPopup()\n\
+ <ButtonPress>: SendRFBEvent()\n\
+ <ButtonRelease>: SendRFBEvent()\n\
+ <Motion>: SendRFBEvent()\n\
+ <KeyPress>: SendRFBEvent()\n\
+ <KeyRelease>: SendRFBEvent()
+*serverDialog.dialog.label: VNC server:
+*serverDialog.dialog.value:
+*serverDialog.dialog.value.translations: #override\n\
+ <Key>Return: ServerDialogDone()
+*passwordDialog.dialog.label: Password:
+*passwordDialog.dialog.value:
+*passwordDialog.dialog.value.AsciiSink.echo: False
+*passwordDialog.dialog.value.translations: #override\n\
+ <Key>Return: PasswordDialogDone()
+*popup.title: TightVNC popup
+*popup*background: grey
+*popup*font: -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
+*popup.buttonForm.Command.borderWidth: 0
+*popup.buttonForm.Toggle.borderWidth: 0
+*popup.translations: #override <Message>WM_PROTOCOLS: HidePopup()
+*popup.buttonForm.translations: #override\n\
+ <KeyPress>: SendRFBEvent() HidePopup()
+*popupButtonCount: 8
+*popup*button1.label: Dismiss popup
+*popup*button1.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: HidePopup()
+*popup*button2.label: Quit viewer
+*popup*button2.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: Quit()
+*popup*button3.label: Full screen
+*popup*button3.type: toggle
+*popup*button3.translations: #override\n\
+ <Visible>: SetFullScreenState()\n\
+ <Btn1Down>,<Btn1Up>: toggle() HidePopup() ToggleFullScreen()
+*popup*button4.label: Clipboard: local -> remote
+*popup*button4.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: SelectionToVNC(always) HidePopup()
+*popup*button5.label: Clipboard: local <- remote
+*popup*button5.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: SelectionFromVNC(always) HidePopup()
+*popup*button6.label: Request refresh
+*popup*button6.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: SendRFBEvent(fbupdate) HidePopup()
+*popup*button7.label: Send ctrl-alt-del
+*popup*button7.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: SendRFBEvent(keydown,Control_L)\
+ SendRFBEvent(keydown,Alt_L)\
+ SendRFBEvent(key,Delete)\
+ SendRFBEvent(keyup,Alt_L)\
+ SendRFBEvent(keyup,Control_L)\
+ HidePopup()
+*popup*button8.label: Send F8
+*popup*button8.translations: #override\n\
+ <Btn1Down>,<Btn1Up>: SendRFBEvent(key,F8) HidePopup()