summaryrefslogtreecommitdiff
path: root/recipes-graphics/wayland-app-launch/wayland-app-launch/wayland-app-launch.sh.in
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-05-29 20:05:35 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2019-05-29 20:05:35 +0200
commitbe5b0af7fa7fa341363e0ccfe0c7f8a85213d37f (patch)
treef4ce1d362df034210608c39e9206f3b68ee0e0a7 /recipes-graphics/wayland-app-launch/wayland-app-launch/wayland-app-launch.sh.in
parentc8aea6d76d570377053854ca4f722395236aa095 (diff)
wayland-app-launch: add a simple systemd service
This tries to start a wayland application after weston got started. Create a copy of wayland-terminal-launch_1.0.bb with the variables changed according to your needs. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics/wayland-app-launch/wayland-app-launch/wayland-app-launch.sh.in')
-rw-r--r--recipes-graphics/wayland-app-launch/wayland-app-launch/wayland-app-launch.sh.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-graphics/wayland-app-launch/wayland-app-launch/wayland-app-launch.sh.in b/recipes-graphics/wayland-app-launch/wayland-app-launch/wayland-app-launch.sh.in
new file mode 100644
index 0000000..411184b
--- /dev/null
+++ b/recipes-graphics/wayland-app-launch/wayland-app-launch/wayland-app-launch.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+if test -z "$XDG_RUNTIME_DIR"; then
+ export XDG_RUNTIME_DIR=/run/user/`id -u`
+ if ! test -d "$XDG_RUNTIME_DIR"; then
+ mkdir --parents $XDG_RUNTIME_DIR
+ chmod 0700 $XDG_RUNTIME_DIR
+ fi
+fi
+
+# wait for weston
+while [ ! -e $XDG_RUNTIME_DIR/wayland-0 ] ; do sleep 0.1; done
+sleep 0.5
+
+@@wayland-application@@