summaryrefslogtreecommitdiff
path: root/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bbappend
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-12-17 23:08:34 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2012-12-17 23:08:34 +0100
commitad2952e612289d8fddad13f2818dff63ea6aee86 (patch)
tree38b5a976d135e9fd7a3c0ade55ef3bee425c8aef /recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bbappend
parented5e0e484a2d61b1e140d2a5509e08086af6cbc9 (diff)
xinput-calibrator: make the menuentry behaviour as the one time calibration on first boot
Diffstat (limited to 'recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bbappend')
-rw-r--r--recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bbappend8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bbappend b/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bbappend
index e12abec..2d5a610 100644
--- a/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bbappend
+++ b/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bbappend
@@ -1,6 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
inherit systemd
@@ -8,3 +8,9 @@ SRC_URI += "file://xinput-calibrator.service"
SYSTEMD_PACKAGES = "${PN}-systemd"
SYSTEMD_SERVICE = "${PN}.service"
+
+# menu entry should make the calibration permanent instead of printing cal data into a terminal
+do_install_append() {
+ install -m 0755 ${D}/usr/share/applications/xinput_calibrator.desktop ${D}/usr/share/applications/xinput_calibrator.desktop.old
+ sed -i -e 's/xinput_calibrator; cat/rm -f \/etc\/pointercal.xinput; xinput_calibrator_once.sh/' ${D}/usr/share/applications/xinput_calibrator.desktop
+} \ No newline at end of file