summaryrefslogtreecommitdiff
path: root/recipes-graphics
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2013-03-08 17:51:34 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2013-09-22 11:00:11 +0200
commit875596150be8dc72d23e28004e2535a1f5e4f363 (patch)
treec569a88489b0d0505592d6d1c5512bcc28961194 /recipes-graphics
parentfff9d61cb26e78068bdbdd8a935056689acb74fe (diff)
xinput-calibrator: menuentry behaves as the first boot calibration
- make the menuentry behave as the one time calibration on first boot
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend b/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
index e12abec..2d5a610 100644
--- a/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
+++ b/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bbappend
@@ -1,6 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PRINC := "${@int(PRINC) + 1}"
+PRINC := "${@int(PRINC) + 2}"
inherit systemd
@@ -8,3 +8,9 @@ SRC_URI += "file://xinput-calibrator.service"
SYSTEMD_PACKAGES = "${PN}-systemd"
SYSTEMD_SERVICE = "${PN}.service"
+
+# menu entry should make the calibration permanent instead of printing cal data into a terminal
+do_install_append() {
+ install -m 0755 ${D}/usr/share/applications/xinput_calibrator.desktop ${D}/usr/share/applications/xinput_calibrator.desktop.old
+ sed -i -e 's/xinput_calibrator; cat/rm -f \/etc\/pointercal.xinput; xinput_calibrator_once.sh/' ${D}/usr/share/applications/xinput_calibrator.desktop
+} \ No newline at end of file